uva 10892 LCM Cardinality

原题:
A pair of numbers has a unique LCM but a single number can be the LCM of more than one possible pairs. For example 12 is the LCM of (1, 12), (2, 12), (3,4) etc. For a given positive integer N, the number of different integer pairs with LCM is equal to N can be called the LCM cardinality of that number N. In this problem your job is to find out the LCM cardinality of a number.
Input
The input file contains at most 101 lines of inputs. Each line contains an integer N (0 < N ≤ 2∗10 9 ).
Input is terminated by a line containing a single zero. This line should not be processed.
Output
For each line of input except the last one produce one line of output. This line contains two integers
N and C. Here N is the input number and C is its cardinality. These two numbers are separated by a
single space.
Sample Input
2
12
24
101101291
0
Sample Output
2 2
12 8
24 11
101101291 5
中文:
给你一个数n,让你找出能形成最小公倍数为n的两个数的个数。

#include <bits/stdc++.h>
using namespace std;
long p[150001];
bool tag[150001];

int get_prime()
{
    long cnt=0;
    for(long i=2;i<150001;i++)
    {
        if(!tag[i])
            p[cnt++]=i;
        for(long j=0;j<cnt&&p[j]*i<150001;j++)
        {
            tag[i*p[j]]=1;
            if(i%p[j]==0)
                break;
        }
    }
    return cnt;
}
long decomposition(long x)
{
    long k=0,cnt,res=1;
    while(x>1)
    {
        cnt=0;
        while(x%p[k]==0)
        {
            x/=p[k];
            cnt++;
        }
        res*=(cnt*2)+1;
        k++;
    }
    return res;
}
int main()
{
    ios::sync_with_stdio(false);
    cout<<get_prime();
    long n;
    while(cin>>n,n)
    {
        if(n==1)
            cout<<n<<" "<<1<<endl;
        else
        {
            long ans=decomposition(n);
            cout<<n<<" "<<ans/2+1<<endl;
        }
    }
    return 0;
}

解答:
先在纸上写一写发现,如果两个数要是能形成最小公倍数为n,那么必须要满足如下的形式。
首先把n用唯一分解定理分解可以得到
n=pa11pa22pann
如果要想有两个数a,b的公倍数的是n。那么a用唯一分解定理分解,b用唯一分解定理分解,a和b的相同素因子的系数取最大的那个必须要等于 ai
也就是最小公倍数的那个公式
n=pmax{x1,y1}1pmax{x2,y2}2pmax{xn,yn}n
其中 xi 为a分解后素因子的系数, yi 为b分解后的素因子的系数。 max{xi,yi}=ai
那么如果 xi ai 的时候 bi 可以取得0到 ai1 的任意一个数,同理 bi
不过两个数(a,b)和(b,a)会重复(n,n)也会重复。所以要除以2加1。
先筛个素数表,然后用唯一分解定理找出所有质因子的个数。最后计算即可

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值