HDU-4496-逆向并查集

Problem Description
Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.

Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.

Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.

Sample Input

5 10
0 1
1 2
1 3
1 4
0 2
2 3
0 4
0 3
3 4
2 4

Sample Output

1
1
1
2
2
2
2
3
4
5
Hint

The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there’s only 1 connected block at first.
The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together.
But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block.
Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.

题目大意:

给出一张图,按照给定边的顺序逐个删除。问每删除一条边后图的连通块数是多少?

解题思路:

逆向并查集求连通块数。假设一开始的时候所有点都不连通,从给定边的逆序即从最后

一条边开始添加,如果新添加的边连通了两个连通分量,则连通块数就减一,否则不改变。将

每次加边后的连通块数存起来,最后输出。


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=10010;
const int maxm=100010;
int a[maxn];
int b[maxm],c[maxm];
int d[maxm];
int num;
int find(int x)
{

    if(a[x]==x)  return a[x];
    a[x]=find(a[x]);
    return a[x];
}
void merge(int x,int y)
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
    {
        num--;
        a[fx]=fy;
    }
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {

        int i,j;
        for(i=0;i<n;i++)
        {
            a[i]=i;
        }
        for(i=0;i<m;i++)
        {
            scanf("%d%d",&b[i],&c[i]);
        }
        num=n;
        for(i=m-1;i>=1;i--)  //逆向查找
        {
            merge(b[i],c[i]);
            d[i]=num;
        }
        d[m]=n;
        for(i=1;i<=m;i++)
        {
            printf("%d\n",d[i]);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值