L2-006 树的遍历 (25分) | dfs bfs

L2-006 树的遍历 (25分)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

ac代码 

#include <bits/stdc++.h>
using namespace std;
struct Node{
    int val,l,r;
}node[31];
int b[31],c[31],tot=0;

int dfs(int num,int b[],int c[]) //建树
{
    if(num<=0) return -1;
    if(num==1)
    {
        node[++tot].val=b[1];
        node[tot].l=node[tot].r=-1;
        return tot;
    }
    node[++tot].val=c[num];
    int res=tot,pos;
    for(pos=1;pos<=num;pos++)
        if(b[pos]==c[num]) break;
    node[res].l=dfs(pos-1,b,c);
    node[res].r=dfs(num-pos,b+pos,c+pos-1);
    return res;
}

void bfs()
{
    queue <int> q;
    q.push(1);
    while(q.size())
    {
        int cur=q.front();
        q.pop();
        if(cur!=1) cout<<' ';
        cout<<node[cur].val;
        if(node[cur].l!=-1) q.push(node[cur].l);
        if(node[cur].r!=-1) q.push(node[cur].r);
    }
}

int main()
{
    int num;
    cin>>num;
    for(int i=1;i<=num;i++) cin>>c[i];//后序
    for(int i=1;i<=num;i++) cin>>b[i];//中序
    dfs(num,b,c);
    bfs();
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值