1135. Is It A Red-Black Tree (30)
There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:
(1) Every node is either red or black.
(2) The root is black.
(3) Every leaf (NULL) is black.
(4) If a node is red, then both its children are black.
(5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.
For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.
|
|
|
|
|
|
For each given binary search tree, you are supposed to tell if it is a legal red-black tree.
Input Specification:
Each input file contains several test cases. The first line gives a positive integer K (<=30) which is the total number of cases. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.
Output Specification:
For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.
Sample Input:3 9 7 -2 1 5 -4 -11 8 14 -15 9 11 -2 1 -7 5 -4 8 14 -15 8 10 -7 5 -6 8 15 -11 17Sample Output:
Yes No No
前序遍历和中序遍历建立二叉树的同时,判断左右子树到叶子节点的黑色节点数是否相同,如果相同,更新根节点的黑色节点数目。
如果根节点是红的,其子节点一定是黑的。
//#include "stdafx.h"
#include<cstdio>
#include<iostream>
#include<map>
#include<vector>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=35;
int n;
struct node{
int data;
int flag;
node *l,*r;
};
int flag[maxn];
int pre[maxn];
int in[maxn];
int f=0;
node* create(int l1,int r1,int l2,int r2,int &num){
if(l1>r1||l2>r2){num=1;return NULL;}
int i=l2;
node* no=new node;
no->data=pre[l1];
no->flag=flag[l1];
for(;i<=r2;i++)
if(pre[l1]==in[i])break;
int n1,n2;
no->l=create(l1+1,i-l2+l1,l2,i-1,n1);
no->r=create(i-l2+l1+1,r1,i+1,r2,n2);
if(n1==n2){
if(no->flag==1)
num=n1;
else num=n1+1;
}
else {f=1;}
if(no->flag==1){
if((no->l!=NULL&&no->l->flag==1)||(no->r!=NULL&&no->r->flag==1))
{
f=1;}
}
return no;
}
int change(string s){
int ans=0;
for(int i=0;i<s.length();i++)
ans=ans*10+s[i]-'0';
return ans;
}
int main(){
// freopen("c://jin.txt","r",stdin);
int k;
cin>>k;
string s;
while(k--){
cin>>n;
f=0;
memset(flag,0,sizeof(flag));
for(int i=0;i<n;i++)
{cin>>s;
if(s[0]=='-'){flag[i]=1;
s.erase(s.begin());}
in[i]=pre[i]=change(s);
}
sort(in,in+n);
if(flag[0]==1){cout<<"No"<<endl;continue;}
int num=0;
node* root=create(0,n-1,0,n-1,num);
if(f){cout<<"No"<<endl;continue;}
cout<<"Yes"<<endl;
}
// freopen("CON","r",stdin);
// system("pause");
return 0;
}