HDOJ-1509(stl priority queue)

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1926    Accepted Submission(s): 752


Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
 

Input
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
 

Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.
 

Sample Input
  
  
GET PUT msg1 10 5 PUT msg2 10 4 GET GET GET
 

Sample Output
  
  
EMPTY QUEUE! msg2 10 msg1 10 EMPTY QUEUE!
 

Author
ZHOU, Ran



//相当蛋疼  WA多次, 后来加了一个按时间顺序排序,  难道不是自动按相同优先级的话按时间顺序排序么?
#include<iostream>
#include<stdio.h>
#include<queue>
using namespace std;
struct Node{
    string s;
    int w;
    int t;
    friend bool operator < (Node a,Node b) { 
        if(a.w != b.w)
            return a.w > b.w;
        else
            return a.t > b.t;
    }

};
priority_queue<Node>Q;
int main()
{
    string sth,p;
    int x,y;
    int time=0;
    while(cin>>sth)
    {
        if(sth=="GET"){
            if(Q.empty()){
                cout<<"EMPTY QUEUE!"<<endl;
            }
            else{
                cout<<Q.top().s<<endl;
                Q.pop();
            }
        
        }
        else if(sth=="PUT"){
            cin>>sth>>x>>y;
            char tmp[100];
            sprintf(tmp," %d",x);
            sth+=tmp;
            Node n ;
            n.s=sth;
            n.w=y;
            n.t=time++;
            Q.push(n);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值