BFS

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes. 
题意:在一维空间中,求由一个数字到另个数字的最短变化步数,数字的变化可以是加1减一或者乘以二。
思路:本题采用广搜,当最先搜到结果即为最短路径。

#include <iostream>
#include<stdio.h>
#include<queue>

using namespace std;
bool flag[100010];//标志数组,标记元素是否搜过
int s[3]={1,-1,0};//广搜的路径
int q[3]={1,1,2};//广搜的路径
struct Node
{
    int x,t;//x代表坐标,t代表步数
}pre,cur;
void bfs(int a,int b)
{
    if(a!=b)//起点终点不同
    {
    queue<Node> que;//与结构体相关的队列
    while(!que.empty()) que.pop();
    pre.x=a;
    pre.t=0;
    flag[a]=1;
    que.push(pre);//起点进队列
    while(!que.empty())
    {
        pre=que.front(); que.pop();//每次取队首元素作为当前节点 ,出队列
        for(int i=0;i<3;i++)//广搜
        {
            int xx=q[i]*pre.x+s[i];
            if(xx>=0&&xx<=100000&&!flag[xx])
             {
                 cur.x=xx;
                flag[xx]=1;//已经搜过
                cur.t=pre.t+1;
                que.push(cur);
                if(cur.x==b) printf("%d\n",cur.t);//判断是否搜到终点
             }


        }
    }
    }
    if(a==b) printf("0\n");//起点终点相同
}

int main()
{
    int N,K;
    scanf("%d%d",&N,&K);
    bfs(N,K);


    return 0;
}

注意:必须要在广搜进行的同时判断是否搜到,不能在出队列时在判断,这样会超时。
标注:广搜思路:
一维广搜:把起点进入队列,然后出队列依次广搜周围的目标,如果目标满足条件进入队列,并且标志数组标记已访问,每次都访问队首元素,依次递归下去,直到搜到目标为止。
二维广搜:依次从两点出发进行广搜。
   

                           
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值