BFS和DFS

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100

111111111111111111


题意:给一个小于200的整数n,找到m他的十进制数只含有0和1,m能整除n,找到一个即可。用深搜比较简单。

#include<iostream>
  #include<cstdlib>
  #include<cstdio>
  #include<cstring>
  #include<algorithm>
  #include<cmath>
  #include<queue>
  using namespace std;
  bool found;
 void DFS(unsigned __int64 t ,int n,int k)
 {
     if(found)
         return ;//如果已经发现了答案就没搜的必要了
     if(t%n==0)
     {//发现答案,输出,标记变量该true
         printf("%I64u\n",t);
         found=true;
         return ;
     }
     if(k==19)//到第19层,回溯
         return ;
     DFS(t*10,n,k+1);    //搜索×10
     DFS(t*10+1,n,k+1);    //搜索×10+1
 }
 int main()
 {
     int n;
     while(cin>>n,n)
     {
         found=false;//标记变量,当为true代表搜到了题意第一的m
         DFS(1,n,0);    //从1开始搜n的倍数,第三个参数代表搜的层数,当到第19层时返回(因为第20层64位整数存不下)
     }
     return 0;
 }

这题用广搜也可以:


#include<iostream>  
#include<queue>  
using namespace std;  
int n;  
long long BFS()  
{  
    long long t;  
    queue<long long>q;  
    while(!q.empty())  
        q.pop();  
    q.push(1);  
    while(1)  
    {  
        t = q.front();  //t取队首元素
        if(t%n==0)  
            return t;  
        q.pop();  //出队
        q.push(t*10);  
        q.push(t*10+1);  
    }  
}  
int main()  
{  
    while(cin>>n, n)  
    {  
        long long res = BFS();  
         cout<<res<<endl;  
    }  
    return 0;  
}








  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值