hdu-1078-FatMouse and Cheese

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3698    Accepted Submission(s): 1470


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse已存储一些奶酪在一个城市。这个城市可以被视为一个维数为n正方形网格:每个网格位置贴上标签(p,q),0 < = p < n和0 < =问< n。在每个网格位置Fatmouse已经藏在0和100块的奶酪洞中。现在他打算享受他最喜欢的食物。


FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

FatMouse首先站在位置(0,0)。他吃了奶酪,他站,然后要么横向或者纵向运行到另一个位置。问题是,有一个超级的小猫坐在他的洞附近的头号杀手,所以每次他可以运行最多k位置进入洞被头号杀手抓住之前。更糟的是——在一个位置吃了奶酪后,FatMouse变得更胖。所以为了获得足够的能量,在他的往下一个位置跑的时候,他跑到一个地点,有更多的块的奶酪比那些在当前的孔。


Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
 

Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The input ends with a pair of -1's.
 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
 

Sample Input
  
  
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
  
  
37
 

Source
import java.util.Scanner;

public class Main {

	/**
	 * @param args
	 */
	static int[][] a;
	static int[][] b;
	static int n;
	static int K;
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner input=new Scanner(System.in);
		while(true){
			n=input.nextInt();
			K=input.nextInt();
			if(n==-1&&K==-1)
				break;
			a=new int[n][n];
			b=new int[n][n];
			for(int i=0;i<n;i++)
				for(int j=0;j<n;j++)
					a[i][j]=input.nextInt();
			int max=0;
			for(int i=0;i<n;i++)
				for(int j=0;j<n;j++){
					int temp=dfs(i,j);
					if(temp>max)
						max=temp;
				}
			System.out.println(max);
		}
	}
	private static int dfs(int i, int j) {
		// TODO Auto-generated method stub
		int max=0;
		int temp;
		if(b[i][j]!=0)
			return b[i][j];
		for(int k=1;k<=K;k++){//1-K
			//上
			if(i-k>=0&&a[i-k][j]>a[i][j]){
				temp=dfs(i-k,j);
				if(temp>max)
					max=temp;
			}
			//下
			if(i+k<n&&a[i+k][j]>a[i][j]){
				temp=dfs(i+k,j);
				if(temp>max)
					max=temp;
			}
			//左
			if(j-k>=0&&a[i][j-k]>a[i][j]){
				temp=dfs(i,j-k);
				if(temp>max)
					max=temp;
			}
			//右
			if(j+k<n&&a[i][j+k]>a[i][j]){
				temp=dfs(i,j+k);
				if(temp>max)
					max=temp;
			}
		}
		return b[i][j]=max+a[i][j];
		
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值