hdoj1237简单计算器

Description

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。 
 

Input

测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。 
 

Output

对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。 
 

Sample Input

    
    
1 + 2 4 + 2 * 5 - 7 / 11 0
 

Sample Output

    
    
3.00 13.36
 代码如下:
#include<stdio.h>
#include<stack>
#include<string.h>
#include<algorithm>
using namespace std;
char str[220];
int main()
{
	double b,x,sum;
	int sign;
	char c;
	while(1)
	{
		sign=0;
		stack<double>st;
		scanf("%lf",&b);
		st.push(b);
		while(getchar()!='\n')
		{
			sign=1;
			scanf("%c%lf",&c,&b);
			if(c=='+')
			st.push(b);
			else if(c=='-')
			st.push(-b);
			else if(c=='*')
			{
			x=st.top();
			x=x*b;
			st.pop();
			st.push(x);	
			}
			else
			{
				x=st.top();
				x=x/b;
				st.pop();
				st.push(x);
			}
			
		}
		if(!sign)
		break;
		sum=0;
		while(!st.empty())
			{
				sum+=st.top();
				st.pop();
			}
			printf("%.2lf\n",sum);
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值