POJ2631Roads in the North

Description

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

Output

You are to output a single integer: the road distance between the two most remote villages in the area.

Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output

22
树的直径模板题,感觉输入有点问题,没有结束输入的条件,但提交上就对了
代码:
#include<stdio.h>
#include<cstring>
#include<queue>
#include<algorithm>
const int MAX=300300;
using namespace std;
int head[MAX];
bool vis[MAX];
int ans=0,pt;
int dist[MAX]; 
int edgenum;
struct node{
	int from,to,val,next;
}edge[MAX*2];
void init()
{
	memset(head,-1,sizeof(head));
	edgenum=0;
}
void add(int u,int v,int w)
{
	edge[edgenum].from=u;
	edge[edgenum].to=v;
	edge[edgenum].val=w;
	edge[edgenum].next=head[u];
	head[u]=edgenum++;
}
void bfs(int s)
{
	memset(dist,0,sizeof(dist));
	memset(vis,0,sizeof(vis));
	queue<int>que;
	que.push(s);
	vis[s]=true;
	dist[s]=0;
	ans=0;
	pt=s;
	while(!que.empty())
	{
		int u=que.front();
		que.pop();
		for(int i=head[u];i!=-1;i=edge[i].next)
	  {
		 int v=edge[i].to;
		  if(!vis[v])
		   {
            if(dist[v]<dist[u]+edge[i].val)
               {
            	 dist[v]=dist[u]+edge[i].val;
            	 if(ans<dist[v])
            	 {
            	 ans=dist[v];
            	 pt=v;	
				 }
            	 
			   }
			   
		  	vis[v]=true;
		    que.push(v);
	    	}
	
	   }	
	}

}
void solve()  
{  
    bfs(1);  
    bfs(pt);  
    printf("%d\n", ans);  
} 
int main()
{
	int n,m,a,b,c;
	init();
    while(scanf("%d%d%d",&a,&b,&c)!=EOF)
    {
    	add(a,b,c);
    	add(b,a,c);	
	}
    solve();
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值