A Knight's Journey

A Knight’s Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 34085 Accepted: 11621

Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, … , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, …

Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Diffculty:字典的顺序扩展方向 DFS
初始状态:从A1开始,个数为1;
扩展方式:按走‘日’字形8个方向;
目标状态:棋盘全部遍历到

#include<cstdio>
#include<cstring>
int vis[1000][1000];
int dx[] = {-1,1,-2,2,-2,2,-1,1};
int dy[] = {-2,-2,-1,-1,1,1,2,2};
int p,q,sum,flag,t;
int cnt=1;
typedef struct point
{
    int line;
    int column;
};
point path[1000];
bool isover(int x,int y)
{
    if(x>=p||x<0||y>=q||y<0)
    return 1;
    return 0;
}//判断是否越界
void dfs(int x,int y,int sum)
{if(sum==p*q)//目标状态:棋盘全部遍历到
{flag=1;
for(int k=0;k<sum;k++)
printf("%c%d",path[k].column+'A',path[k].line+1);
return;}
vis[x][y]=1;
for(int i=0;i<8;i++)//扩展方式:按走‘日’字形8个方向;
{int ny=y+dy[i];
int nx=x+dx[i];
if(!vis[nx][ny]&&!isover(nx,ny)&&!flag)//判断越界,标记,是否有一存在条路
{path[sum].column=ny;
path[sum].line=nx;
dfs(nx,ny,sum+1);
}
}vis[x][y]=0;}
int main()
{scanf("%d",&t);
while(t--)
{scanf("%d%d",&p,&q);
memset(vis,0,sizeof(vis));
flag=0;
printf("Scenario #%d:\n", cnt);
path[0].column=0;
path[0].line=0;
vis[0][0]=1;
dfs(0,0,1);//初始状态:从A1开始,个数为1;
if(flag==0)
printf("impossible");
printf(cnt==t?"\n":"\n\n");//对输出格式的控制;
cnt++;
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值