杭电5631 Minimum Cut-Cut

 Minimum Cut-Cut

Time Limit: 1000MS      Memory Limit: 65536KB      64bit IO Format: %I64d & %I64u

Description

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them: 

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph. 

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected. 

It is too difficult for Rikka. Can you help her?

Input

The first line contains a number  T(T30) ——The number of the testcases. 

For each testcase, the first line contains a number  n(n100)

Then n+1 lines follow. Each line contains two numbers  u,v  , which means there is an edge between u and v.

Output

For each testcase, print a single number.

Sample Input

1
3
1 2
2 3
3 1
1 3

Sample Output

9
n个结点至少有n-1条边,所以可以去掉一条或两条边,枚举就行了

#include<stdio.h>
#include<string.h>
int n;
struct node{
	int f,t;
}num[110];
int pre[110];
int find(int x)
{
	while(x!=pre[x])
	x=pre[x];
	return x;
 } 
void merge(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	pre[fx]=fy; 
}
void init()
{
	for(int i=1;i<=n;i++)
	pre[i]=i;
}
int main()
{
	int t,i,j,k;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<=n;i++)
	     scanf("%d%d",&num[i].f,&num[i].t);
		  int ans=0;
	     for(i=0;i<=n;i++)
	     {
	     	init();
	     	for(j=0;j<=n;j++)
	        {
	     	  if(j!=i)
	     	  merge(num[j].f,num[j].t);
		    }
		    int sum=0;
		    for(j=1;j<=n;j++)
		    if(pre[j]==j)
		    sum++;
		    if(sum==1)
		    ans++;
		 }
	     for(i=0;i<=n;i++)
	     {
	     	for(j=i+1;j<=n;j++)
	     	{
	     		init();
	     		 for(k=0;k<=n;k++)
	     		 {
	     		 	if(k!=j&&k!=i)
	     		 	merge(num[k].f,num[k].t);
				  }
				  int sum=0;
	              for(k=1;k<=n;k++)
	              if(pre[k]==k)
	              sum++;
	              if(sum==1)
	              ans++;
			 }
	     }
	     printf("%d\n",ans);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值