数据结构C++版 王红梅 OJ习题

1040: 快速排序(2)

Description

已知快速排序的部分代码如下,勿改动,请利用栈实现快速排序非递归函数:void QuickSort();   //quickSort

#include<iostream>

using namespace std;

const int MaxSize=100;

class List

{

private:

int r[MaxSize+1];

int n;

public:

    List(){n=0;} //empty list

void InsertR(int k)  //表尾插入

{  r[++n]=k;}

void Display();      //display

void QuickSort();   //quickSort

};



void List::Display()

{

for(int i=1;i<=n;i++)

       cout<<r[i]<<" ";  

cout<<"\n";

}

int main()

{

List L;

while(1)

{

int k;

cin>>k;

if(!k) break;

        L.InsertR(k);

}

L.Display();

L.QuickSort();

L.Display();

return 0;

}

Input

Output

Sample Input

12 21 32 2 4 24 21 432 23 9 0

Sample Output

12 21 32 2 4 24 21 432 23 9 
2 4 9 12 21 21 23 24 32 432 
//
// Created by Legends丶Hu on 2020/2/8.
//

#include<iostream>
//#include "Stack.h"

using namespace std;

const int StackSize = 100;

template<class T>
class Stack {
private:
    int top;
    T data[StackSize];
public:
    Stack();

    void Push(T x);

    T Pop();

    T GetTop();

    int Empty();

    ~Stack() {}
};

template<class T>
void Stack<T>::Push(T x) {
    if (top == StackSize - 1) throw "Overflow";
    data[++top] = x;
}

template<class T>
Stack<T>::Stack() {
    top = -1;
}

template<class T>
T Stack<T>::Pop() {
    if (Empty()) throw "Downflow";
    return data[top--];
}

template<class T>
T Stack<T>::GetTop() {
    return Empty() ? throw "Downflow" : data[top];
}

template<class T>
int Stack<T>::Empty() {
    return top == -1;
}

const int MaxSize = 100;

class List {
private:
    int r[MaxSize + 1];
    int n;
public:
    List() { n = 0; } //empty list
    void InsertR(int k)  //表尾插入
    { r[++n] = k; }

    void Display();      //display
    void QuickSort();   //quickSort
};

int Partition(int r[], int first, int end) {
    int i = first, j = end;
    while (i < j) {
        while (i < j && r[i] <= r[j])j--;
        if (i < j) {
            swap(r[i], r[j]);
            i++;
        }
        while (i < j && r[i] <= r[j])i++;
        if (i < j) {
            swap(r[i], r[j]);
            j--;
        }
    }
}

void List::QuickSort() {
    Stack<pair<int, int> > s;
    int first = 1, end = n;
    s.Push(make_pair(first, end));
    while (!s.Empty()) {
        pair<int, int> p = s.Pop();
        int pivot = Partition(r, p.first, p.second);
        if (p.first < pivot - 1)s.Push(make_pair(p.first, pivot - 1));
        if (pivot + 1 < p.second)s.Push(make_pair(pivot + 1, p.second));
    }
}

void List::Display() {
    for (int i = 1; i <= n; i++)
        cout << r[i] << " ";
    cout << "\n";
}

int main() {
    List L;
    while (1) {
        int k;
        cin >> k;
        if (!k) break;
        L.InsertR(k);
    }
    L.Display();
    L.QuickSort();
    L.Display();
    return 0;
}

  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值