现给出两人的交锋记录,请统计双方的胜、平、负次数,并且给出双方分别出什么手势的胜算最大。
输入格式:
输入第1行给出正整数N(<=105),即双方交锋的次数。随后N行,每行给出一次交锋的信息,即甲、乙双方同时给出的的手势。C代表“锤子”、J代表“剪刀”、B代表“布”,第1个字母代表甲方,第2个代表乙方,中间有1个空格。
输出格式:
输出第1、2行分别给出甲、乙的胜、平、负次数,数字间以1个空格分隔。第3行给出两个字母,分别代表甲、乙获胜次数最多的手势,中间有1个空格。如果解不唯一,则输出按字母序最小的解。
输入样例:
10
C J
J B
C B
B B
B C
C C
C B
J B
B C
J J
输出样例:
5 3 2
2 3 5
B B
package cn.hjy.testy.Test1018;
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
// 0 1 2 表示J的胜平负
int[] score = new int[3];
int JB = 0, JC = 0, JJ = 0;
int YB = 0, YC = 0, YJ = 0;
for (int i = 0; i < n; i++) {
char j = sc.next().charAt(0);
char y = sc.next().charAt(0);
if (j == 'C') {
if (y == 'C') {
score[1]++;
} else if (y == 'J') {
score[0]++;
JC++;
} else {
score[2]++;
YB++;
}
} else if (j == 'J') {
if (y == 'C') {
score[2]++;
YC++;
} else if (y == 'J') {
score[1]++;
} else {
score[0]++;
JJ++;
}
} else {
// j=='B'
if (y == 'C') {
score[0]++;
JB++;
} else if (y == 'J') {
score[2]++;
YJ++;
} else {
score[1]++;
}
}
}
System.out.println(score[0] + " " + score[1] + " " + score[2]);
System.out.println(score[2] + " " + score[1] + " " + score[0]);
int Jmax = JB;
char Jans = 'B';
if(Jmax < JC) {
Jmax = JC;
Jans = 'C';
}
if(Jmax < JJ) {
Jans = 'J';
}
System.out.print(Jans + " ");
int Ymax = YB;
char Yans = 'B';
if(Ymax < YC) {
Ymax = YC;
Yans = 'C';
}
if(Ymax < YJ) {
Yans = 'J';
}
System.out.print(Yans);
}
}