n a^o7 !

THINK
刚看到 这么长的 英文题时 觉得挺难的, 后来 仔细看的时候 发现 这是 水题 !!!,其实就是 上下颠倒阅读 字符串。。。。用了一堆的if else。
找到各自的对应关系就可以了。

Problem Description

All brave and intelligent fighters, next you will step into a distinctive battleground which is full of sweet and happiness. If you want to win the battle, you must do warm-up according to my instructions, which can make you in the best state preparing to fight. Now please relax yourself and enjoy the good moment. Before you raise your sharp sword to the enemy who guards the battleground, please allow me to tell you a true and romantic story about a samurai like you.
Samurai hh fell in love with girl ss, who is charming and demure. He realized the truth that he must spend his remaining life with ss, and resolved to pursue the hard-won affection. One day hh wrote a letter to ss, when she opens the letter with excitement her mind was in tangle. She found herself completely not to figure out the meaning about the letter, which said that “n 55!w ! pue n a^o7 ! n paau !”. ss also immersed herself in guessing the meaning of that letter for a long time because of her adore to hh. Finally she called hh to ask the meaning of the letter. On the other side of the phone, hh was too nervous to say. Gradually he calmed down himself and told ss to reverse the letter and read it. Then on both ends of the phone comes the voice at the same time “i need u i love u and i miss u”.
ss wants to tell each of you however you are Brave And Skilled, you shouldn’t forget to express your loyal love and romantic feelings to your prince or princess.
Now the horn sounds for battle,do it by the following input and output. I think each of you will get an “Accepted” in this battle with pleasant mood.

Input

Input contains an integer T in the first line, and then T lines follow .Each line contains a message (only contain ‘n5!wpuea^o7!’ and
’ ‘(space)), the message’s length is no more than 100.
Output

Output the case number and the message. (As shown in the sample output)

Example Input

2
n 55!w ! pue n a^o7 ! n paau !
n5!wpuea^o7

Example Output

Case 1: i need u i love u and i miss u
Case 2: loveandmisu

Hint

Author
2012年”浪潮杯”山东省第三届ACM大学生程序设计竞赛

题目大意:
1. 输入的字符串只包括 n5!wpuea^o7! 以及空格;
2. 在阅读时是 上下颠倒阅读的。

#include<stdio.h>
#include<string.h>
int main()
 {
   int T;
   int d, i;
   char str[105];
   int k;
   scanf("%d",&T);
   getchar();
   k = 0;
   while(T --)
     {
       k ++;
       memset(str, 0, sizeof(str));
       gets(str);
             d = strlen(str);
       for (i = 0;i <= d - 1;i ++)
          {
             if (str[i] == 'n')
                  str[i] = 'u';
              else
                 if (str[i] == '5')
                    str[i] = 's';
                else
                   if (str[i] == '!')
                      str[i] = 'i';
                    else
                     if (str[i] == 'w')
                        str[i] = 'm';
                       else
                          if (str[i] == 'p')
                               str[i] = 'd';
                            else
                               if (str[i] == 'u')
                                   str[i] = 'n';
                                     else
                                        if (str[i] == 'e')
                                          str[i] = 'a';
                                           else
                                             if (str[i] == '^')
                                                str[i] = 'v';
                                                  else
                                                     if (str[i] == 'o')
                                                        str[i] = 'o';
                                                         else
                                                            if (str[i] == '7')
                                                              str[i] = 'l';
                                                                else
                                                                   if (str[i] == 'a')
                                                                      str[i] = 'e';

          }

    printf("Case %d: ",k);
    for (i = d - 1;i >= 0 ;i --)
        {
              printf("%c",str[i]);
        }
        printf("\n");
     }
 return 0;
 }


/***************************************************
User name: team3
Result: Accepted
Take time: 0ms
Take Memory: 104KB
Submit time: 2017-02-18 09:31:45
****************************************************/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值