数据结构实验之排序八:快速排序

Think:
快排就是对冒泡排序的一种优化,分割 递归 比较 排序

Problem Description
给定N(N≤10^5)个整数,要求用快速排序对数据进行升序排列,注意不得使用STL。

Input
连续输入多组数据,每组输入数据第一行给出正整数N(≤10^5),随后给出N个整数,数字间以空格分隔。
Output
输出排序后的结果,数字间以一个空格间隔,行末不得有多余空格。
Example Input

8
49 38 65 97 76 13 27 49

Example Output

13 27 38 49 49 65 76 97

#include<stdio.h>
void sort(int a[],int L, int R);
int main()
{
    int  n, a[100050], t;
    while(scanf("%d",&n)!=EOF)
    {
        for (t = 0;t <= n - 1;t ++)
        {
            scanf("%d",&a[t]);
        }
        sort(a, 0, n - 1);
        for (t = 0;t <= n - 1;t ++)
        {
            if (t == n - 1)
                printf("%d\n",a[t]);
            else
                printf("%d ",a[t]);
        }

   }
    return 0;
}
void sort(int a[],int L, int R)
{
    int x = a[L], i = L, j = R;
    if (L >= R) return ;
    while(i < j)
    {
        while(i < j&&a[j] >= x) j --;
        a[i] = a[j];
        while(i < j&&a[i] <= x) i ++;
        a[j] = a[i];
    }
    a[i] = x;
    sort(a, L, i - 1);
    sort(a, i + 1, R);
}


/***************************************************
User name: 
Result: Accepted
Take time: 0ms
Take Memory: 108KB
Submit time: 2017-02-22 11:17:21
****************************************************/
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值