Easy Game

Think:
确实是很 EASY 的签到题。。。。
判断字符串长度 是奇数或者偶数 然后输出就好了

Problem Description

Fat brother and Maze are playing a kind of special (hentai) game on a string S. Now they would like to count the length of this string. But as both Fat brother and Maze are programmers, they can recognize only two numbers 0 and 1. So instead of judging the length of this string, they decide to judge weather this number is even.
Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains a line describe the string S in the treasure map. Not that S only contains lower case letters.

1 <= T <= 100, the length of the string is less than 10086
Output

For each case, output the case number first, and then output “Odd” if the length of S is odd, otherwise just output “Even”.
Sample Input
4
well
thisisthesimplest
problem
inthiscontest
Sample Output
Case 1: Even
Case 2: Odd
Case 3: Odd
Case 4: Odd

#include<stdio.h>
#include<string.h>
int main()
{
    char str[123456];
    int d;
    int T;
    int kase = 0;
    while(~scanf("%d",&T))
    {
        while(T --)
        {
            scanf("%s", str);
            d = strlen(str);
            printf("Case %d: ", ++ kase);
            if (d % 2 == 0)
                printf("Even\n");
            else
                printf("Odd\n");
            memset(str, 0, sizeof(str));
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值