1119 Pre- and Post-order Traversals (30分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

思路:后序(左右中)和前序(中左右)建树,在划分时,根节点为后序最后一个(或前序第一个),在前序中序找后序倒数第二个数,若前序第一个数和找到的后续第二个数中间没有节点,那么这就会出现不为一的情况,若有节点,那么这些节点就是前序第一个数的左子树,在前序中找到的后续第二个数及其以后的树就为前序第一个数的右子树。

#include<vector>

#include<iostream>

using namespace std;

struct node {

    int data;
    node * lchild;
    node * rchild;

};
bool flag = true;
node * creat_tree(vector<int> &pre, vector<int> &post, int pre_start, int pre_end, int post_strat, int post_end){

    if(pre_start > pre_end || post_strat > post_end){
        return NULL;
    }
    node * root = new node();
    root -> data = post[post_end];

    if(pre_start == pre_end)//caution 如果注释掉会在标记1处出现永远循环的情况
        return root;

    int i;
    for(i = pre_start; i < pre_end; i++ ){

        if(post[post_end - 1] == pre[i]){
            break;
        }
    }
    if(i - pre_start > 1){

        root -> lchild = creat_tree(pre, post, pre_start + 1, i - 1, post_strat, post_strat + i - pre_start -2);
        root -> rchild = creat_tree(pre, post, i, pre_end, post_end - pre_end + i - 1, post_end - 1);

    }else
    {
        flag = false;//not unique
        root -> lchild = creat_tree(pre, post, i, pre_end, post_end - pre_end + i - 1, post_end - 1);//标记1
        // root -> rchild = creat_tree(pre, post, i, pre_end, post_end - pre_end + i - 1, post_end - 1);//标记1


    }
    
    
    
    return root;

}
int cnt = 0;
void in_order(node * t){

    if(t == NULL){
        return;
    }
    in_order(t -> lchild);
    printf("%s%d", cnt == 0 ? "" : " ", t -> data);
    cnt++;
    in_order(t -> rchild);

}
int main(){
    int n;
    cin >> n;
    vector<int> pre_order(n);
    vector<int> post_order(n);

    for(int i = 0; i < n; i++){
        scanf("%d", &pre_order[i]);


    }
    for(int i = 0; i < n; i++){

        scanf("%d", &post_order[i]);


    }

    node * tree = creat_tree(pre_order, post_order, 0, n - 1, 0 , n - 1);
    if(flag){
        printf("Yes\n");
    }else
    {
        printf("No\n");
    }
    
    in_order(tree);
    printf("\n");
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值