1064 Complete Binary Search Tree (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key. 
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key. 
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

题意:给一个序列,建一棵二叉排序树,且也为一棵完全二叉树,并输出此树的层序遍历。

思路:根据中序遍历,需要用反向思维,把原本中序遍历输出的地方改为输入(先对给定序列排序),这样就建好了,经典,刚开始没有想到这个方法~

#include<iostream>
#include<vector>
#include<cmath>
#include<algorithm>
using namespace std;
vector<int> vec;
// int root_num(int num){
//     if(num == 1){
//         return 1;
//     }
//     int h = log(num) / log(2) + 1;
//     cout << h << endl;
//     if((1 + pow(2, h - 1) - 1 + pow(2, h - 2) - 1) >= num){ 
//         return num - (pow(2, h - 2) - 1); //总节点 - 右子树节点数
//     }else
//     {
//         return pow(2, h - 1) - 1 + 1; //左子树节点数 + 1
//     }  
// }
vector<int> tree;
int n;
int flag = 1;
void in_order(int root){

    if(root > n){
        return;
    }
    in_order(root * 2);
    tree[root] = vec[flag++];
    in_order(root * 2 + 1);

}
int main(){

    
    cin >> n;
    vec.resize(n + 1);
    tree.resize(n + 1);
    for(int i = 1; i <= n; i++){
        scanf("%d", &vec[i]);
    }
    sort(vec.begin() + 1, vec.end());
    in_order(1);
    for(int i = 1; i < n; i++){
        printf("%d ", tree[i]);
    }
    printf("%d\n", tree[n]);

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值