Employment Planning

A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order to keep the lowest total cost of the project. 

Input

The input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single '0'. 

Output

The output contains one line. The minimal total cost of the project. 

Sample Input

3 
4 5 6
10 9 11
0

Sample Output

199

 

开始做这道题没有思路,把思维固化为在每一个月使用的人数为规定的最少人数,而这样计算的话对于10 9 8等等这样的数据是正确的,但是说如果给出的数据不是按照从大到小的顺序变化的话,这样写就很有可能不是最优解了!

因为是在学动规的时候做的这道题,所以思路很容易地转化到动规上面,但是这个动规方程真的是把我搞蒙了,怎么想?怎么写?

首先,要求出的是既定月份中的最大数,暂且用maxx表示,求出maxx后就拿第一个月来说,我们的计算范围是从a[i](样例中,a[1]=10,a[2]=9,a[3]=11)到maxx,那么在以后的每一个月的计算中,这种讨论情况也一定要加上,这样求得的结果才是最优解!

其次,既然使用动态规划,我们就要表示出来,用dp[15][1005]去记录数据,就拿第一个月来说

for(int i=a[1];i<=maxx;++i)
        {
            dp[1][i]=cost*i+money*i;
        }

dp[][]记录的是一开始雇佣工人的成本加第一个月的工资

那么随着第一层下标的增加,代表的就是第i个月的总开销

这样,问题就转换到了怎么让本月的开销与上个月的开销结合起来,以实现最后只对dp的第一层下标为最后月份讨论的情况下得出结果,这个时候可以在原有的双层for循环的基础之上增加一层for循环,代表上一个月的雇佣的人数,这样我们就知道本月我们应该雇佣或者解雇多少人,本月雇佣或者解雇的开销以及本月的工资的开销是多少。

for(int i=2;i<=month;++i)
        {
            for(int j=a[i];j<=maxx;++j)
            {
                for(int k=0;k<=maxx;++k)
                {
                    if(k<=j)
                    {
                       dp[i][j]=min(dp[i][j],dp[i-1][k]+(j-k)*cost+j*money);
                    }
                    else
                    {
                        dp[i][j]=min(dp[i][j],dp[i-1][k]+(k-j)*baba_money+j*money);
                    }
                }
            }
        }

就像第一个月,可以雇佣的情况有很多,那么最后一个月的雇佣情况也有很多,因为最后的结果叠加到最后一月,所以对最后一个月的支出情况进行讨论就行了!

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int month;
int cost,money,baba_money;
int a[20];
int dp[15][2000];
int main()
{
    while(~scanf("%d",&month)&&month)
    {
        int maxx=-1;
        memset(a,0,sizeof(a));
        scanf("%d%d%d",&cost,&money,&baba_money);
        for(int i=1; i<=month; ++i)
            {
                scanf("%d",&a[i]);
                maxx=max(maxx,a[i]);
            }
        memset(dp,0x3f3f3f,sizeof(dp));
        for(int i=a[1];i<=maxx;++i)
        {
            dp[1][i]=cost*i+money*i;
        }
        for(int i=2;i<=month;++i)
        {
            for(int j=a[i];j<=maxx;++j)//j代表应该雇佣的人数
            {
                for(int k=0;k<=maxx;++k)//k代表实际雇佣人数人数
                {
                    if(k<=j)//如果实际雇佣人数小于应该雇佣人数,就雇佣(a[i]-k)人
                    {
                       dp[i][j]=min(dp[i][j],dp[i-1][k]+(j-k)*cost+j*money);
                    }
                    else//这个代表的是解雇,雇佣人数为(k-a[i])
                    {
                        dp[i][j]=min(dp[i][j],dp[i-1][k]+(k-j)*baba_money+j*money);
                    }
                }
            }
        }
        int num=0x3f3f3f;
            for(int j=0;j<=maxx;++j)
                num=min(num,dp[month][j]);
        printf("%d\n",num);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值