hdu 1250 Hat's Fibonacci



Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
  
  
100
 

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

斐波那契变形,题中要求的数最大可能到两千多位,直接开二维数组会空间超限,所以可以用a[ ][ ]存取一个四位,五位或八位数等,减小数组的大小,下面以五位数为例,每次算的结果由以前的对10取余改变成对10万取余,输出的时候找到第一位不是0的输出,以后的都按照%05d输出

#include<stdio.h>
#include<string.h>
int a[10001][520];
void fun()
{
    a[1][0]=1;
    a[2][0]=1;
    a[3][0]=1;
    a[4][0]=1;
    for(int i=5; i<10000; i++)
    {
        int t=0;
        for(int j=0; j<=510; j++)
        {
            a[i][j]=a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j]+t;
            t=a[i][j]/100000;
            a[i][j]=a[i][j]%100000;

        }
    }

}
int main()
{
    fun();
    int n;
    while(~scanf("%d",&n))
    {
        int i;
        for( i=510; a[n][i]==0; i--);
        printf("%d",a[n][i]);
        for(int j=i-1; j>=0; j--)
            printf("%05d",a[n][j]);
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值