HDU 1250 Hat's Fibonacci

Problem Description

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.

Input

Each line will contain an integers. Process to end of file.

Output

For each case, output the result in a line.

Sample Input

100

Sample Output

4203968145672990846840663646

题目大意:

数组F中,F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4),输入一个数n让你输出F[n]

#include <iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int a[7500][600];
int main()
{
    int b,c,d,e,f,j,g;
    memset(a,0,sizeof(a));
    a[0][0]=1;a[1][0]=1;a[2][0]=1;a[3][0]=1;
    f=0;g=0;
    for(b=4;b<7500;b++)
    {
        for(j=0;j<=g;j++)
        {
            a[b][j]=a[b-1][j]+a[b-2][j]+a[b-3][j]+a[b-4][j];
        }
        for(j=0;j<=g;j++)      //a数组中数值>=10000时进位
        {
            a[b][j+1]+=a[b][j]/10000;
            a[b][j]%=10000;
        }
        if(a[b][g])
        {
            g++;
        }
    }
    while(cin>>e)
    {
        for(f=g;f>=0;f--)     //判断直到数组a中数不为0时输出
        {
            if(a[e-1][f]!=0)
                break;
        }
        cout<<a[e-1][f];
        f--;
        for(;f>=0;f--)
        {
            printf("%04d",a[e-1][f]);
        }
        cout<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值