树的判定

树的判定

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

输入
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

The number of test cases will not more than 20,and the number of the node will not exceed 10000.
The inputs will be ended by a pair of -1.
输出
For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
样例输入
6 8  5 3  5 2  6 4 5 6  0 0

8 1  7 3  6 2  8 9  7 5 7 4  7 8  7 6  0 0

3 8  6 8  6 4 5 3  5 6  5 2  0 0
-1 -1
样例输出
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
 
   
源代码:
#include <iostream>
#include <string.h>
#include <string>
#include <cstdio>
using namespace std;
int leftt[10005],rightt[10005],father[10005];
int find(int x){       //并查集的查找操作
  if(father[x]==-1)
      return x;
  return find(father[x]);
}

void unionset(int x,int y)
{    //并查集的合并操作
  father[y]=x;
}

int main()
{
  int a,b;
  int count=1;
  while(1)
  {
    memset(father,-1,sizeof(father));
    memset(leftt,0,sizeof(leftt));
    memset(rightt,0,sizeof(rightt));
    scanf("%d%d",&a,&b);
    if(a==-1&&b==-1)
      return 0;
    else if(a==0&&b==0)
      printf("Case %d is a tree.\n",count++);
    else
    {
      int i=1;
      leftt[i]=a;
      rightt[i]=b;
      while(scanf("%d%d",&a,&b)&&a&&b)
      {
        i++;
        leftt[i]=a;
        rightt[i]=b;
      }
      int flag=1;
      for(int j=1;j<=i;++j)
      {
        int x=find(leftt[j]);
        int y=find(rightt[j]);
        if(x==y||y!=rightt[j])
        {     //判断有没有环和在不在一个集合中
          flag=0;
          break;
        }
        unionset(x,y);
      }
      if(flag)
      {
        int xx=find(leftt[1]);
        int tt;
        for(tt=2;tt<=i;++tt)
        {
          if(xx!=find(leftt[tt]))   //如果有某个find(leftt[tt])和xx不相等,说明所有点没在一个集合中,不是树
            break;
        }
        if(tt>i)  //判断节点数是不是比边数大
          printf("Case %d is a tree.\n",count++);
        else
          printf("Case %d is not a tree.\n",count++);
      }
      else
        printf("Case %d is not a tree.\n",count++);
    }
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值