JAVA 大数据 例题

 

用JAVA  实现大数的运算

还没有系统的学过java ,套用的模板

有几点需要注意的:

1、多组输入

     while(cin.hasNext()){

     }

2、判断 输入的 a 是不是 0

     在定义一个变量 c    首先将 c 赋值为 0

     用  a.equals(c)    判断 a 是不是 0

3、清零

     ans=new BigInteger(”0“);

4、用  ans=ans.add(b);  // 来计算 ans+ b 的值

 

eg 1:

One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. “This supercomputer is great,” remarked Chip. “I only wish Timothy were here to see these results.” (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890

123456789012345678901234567890

123456789012345678901234567890

0

Sample Output

370370367037037036703703703670

 

提交时package Bignum;不能交

package Bignum;
import java.util.*;
import java.math.*;
import java.math.BigInteger;
import java.util.Scanner;
 
public class Main {
	public static void main(String args[])
	{
		Scanner cin = new Scanner(System.in);
		BigInteger a;
		BigInteger ans;
		BigInteger c=BigInteger.valueOf(0);
		ans=new BigInteger("0");
		while(cin.hasNext())
		{
			a=cin.nextBigInteger();
			if(a.equals(c))
				break;
			else {
				ans=ans.add(a);
			}
		}
		System.out.println(ans);
		
	}
}

eg 2:

The problem is to multiply two integers X, Y . (0 ≤ X, Y < 10250)

Input

The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer.

Output

For each input pair of lines the output line should consist one integer the product.

Sample Input

12

12

2

222222222222222222222222

Sample Output

144

444444444444444444444444

本题是实现 大数的乘法乘法运算:

用到的是  ans=a.multiply(b);  //  算 a*b 

import java.util.*;
import java.math.*;
import java.math.BigInteger;
import java.util.Scanner;
 
public class Main {
	public static void main(String args[])
	{
		Scanner cin = new Scanner(System.in);
		BigInteger a,b,ans;
		while(cin.hasNext())
		{
			a=cin.nextBigInteger();
			b=cin.nextBigInteger();
			ans=a.multiply(b);
		    System.out.println(ans);
		}
		
	}
}

eg 3:

Sample Input
110 / 100
99 % 10
2147483647 / 2147483647
2147483646 % 2147483647
Sample Output
1
9
1
2147483646

import java.io.*;
import java.util.*;
import java.math.*;
import java.text.*;
public class Main {
 
	public static void main(String args[]) 
	{
		Scanner in = new Scanner(System.in);
        BigInteger a,b;char c;
        while(in.hasNext())
        {
		       a = in.nextBigInteger();
               c=in.next().charAt(0);
		       b = in.nextBigInteger();
		       if(c=='/')
                     System.out.println(a.divide(b));
               else
                     System.out.println(a.mod(b));
                       
         }
    }
}

eg 4:

次方

Sample Input
95.123
0.4321
5.1234
6.7592
98.999
1.0100
12
20
15
9
10
12
Sample Output
548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

import java.util.*;
import java.math.*;
public class Main
{
    public static void main(String args[])
    {
        Scanner cin=new Scanner(System.in);
        BigDecimal ans=new BigDecimal("1");
        BigDecimal a;
        while(cin.hasNext())
        {
        a=cin.nextBigDecimal();
        int n;
        n=cin.nextInt();
        ans=new BigDecimal("1");
        for(int i=1;i<=n;i++)
            ans=ans.multiply(a);
        String str;
        str=ans.stripTrailingZeros().toPlainString();//去除后导0
        if(str.charAt(0)=='0')
            System.out.println(str.substring(1));
        else
            System.out.println(str);
        }
    }
}

这个题没有用java

Write a program that reads an expression consisting of two non-negative integer and an operator.
Determine if either integer or the result of the expression is too large to be represented as a “normal”
signed integer (type integer if you are working Pascal, type int if you are working in C).
Input
An unspecified number of lines. Each line will contain an integer, one of the two operators ‘+’ or ‘*’,
and another integer.
Output
For each line of input, print the input followed by 0-3 lines containing as many of these three messages
as are appropriate: ‘first number too big’, ‘second number too big’, ‘result too big’.
Sample Input
300 + 3
9999999999999999999999 + 11
Sample Output
300 + 3
9999999999999999999999 + 11
first number too big
result too big

#include <cstdio>
#include <cstring>
#include <climits>
#include <cstdlib>
const int inf = INT_MAX;
int main()
{
    double x,y;
    char s1[1010],s2[10],s3[1010];
    while(~scanf("%s%s%s",s1,s2,s3))
    {
        printf("%s %c %s\n",s1,s2[0],s3);
        x = atof(s1);
        y = atof(s3);
        if(s2[0] == '+')
        {
            if(x > inf)
                printf("first number too big\n");
            if(y > inf)
                printf("second number too big\n");
            if(x + y > inf)
                printf("result too big\n");
        }
        if(s2[0] == '*')
        {
            if(x > inf)
                printf("first number too big\n");
            if(y > inf)
                printf("second number too big\n");
            if(x * y > inf)
                printf("result too big\n");
        }
    }
    return 0;
}

 

智能网联汽车的安全员高级考试涉及多个方面的专业知识,包括但不限于自动驾驶技术原理、车辆传感器融合、网络安全防护以及法律法规等内容。以下是针对该主题的一些核心知识解析: ### 关于智能网联车安全员高级考试的核心内容 #### 1. 自动驾驶分级标准 国际自动机工程师学会(SAE International)定义了六个级别的自动驾驶等级,从L0到L5[^1]。其中,L3及以上级别需要安全员具备更高的应急处理能力。 #### 2. 车辆感知系统的组成与功能 智能网联车通常配备多种传感器,如激光雷达、毫米波雷达、摄像头和超声波传感器等。这些设备协同工作以实现环境感知、障碍物检测等功能[^2]。 #### 3. 数据通信与网络安全 智能网联车依赖V2X(Vehicle-to-Everything)技术进行数据交换,在此过程中需防范潜在的网络攻击风险,例如中间人攻击或恶意软件入侵[^3]。 #### 4. 法律法规要求 不同国家和地区对于无人驾驶测试及运营有着严格的规定,考生应熟悉当地交通法典中有关自动化驾驶部分的具体条款[^4]。 ```python # 示例代码:模拟简单决策逻辑 def decide_action(sensor_data): if sensor_data['obstacle'] and not sensor_data['emergency']: return 'slow_down' elif sensor_data['pedestrian_crossing']: return 'stop_and_yield' else: return 'continue_driving' example_input = {'obstacle': True, 'emergency': False, 'pedestrian_crossing': False} action = decide_action(example_input) print(f"Action to take: {action}") ``` 需要注意的是,“同学”作为特定平台上的学习资源名称,并不提供官方认证的标准答案集;建议通过正规渠道获取教材并参加培训课程来准备此类资格认证考试
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值