Zjnu Stadium HDU - 304 加权并查集

题意:

观众席围成一圈。列的总数是300,编号为1–300,顺时针计数,我们假设行的数量是无限的。将有N个人去那里。他对这些座位提出了要求:这意味着编号A的顺时针X距离坐着编号B。例如:A在第4列,X是2,那么B必须在第6列(6=4+2)。现在你的任务是判断请求是否正确。

题目:

In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1–300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1–N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.

Input

There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

Output

For every case:
Output R, represents the number of incorrect request.

Sample Input

10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100

Sample Output

2

Hint

Hint:
(PS: the 5th and 10th requests are incorrect)

思路

1.由于题中明确给出,编号A的顺时针X距离坐着编号B,故x<300,当我们用并查集找到一个祖宗节点时,我们可以将该点看作原点,将圈拉成直线看待。即可忽略成环。

2.b->a, a离”原点更近“

int f(int x)
{
    if(x!=dp[x])
    {
        int t=dp[x];/*因为在递归找祖先的过程中,dp[x]的值会改变,而我们我们只需要找到距离x最近的点,即可得到dp[x]到祖宗节点的距离。所以要记录t的值*/
        dp[x]=f(dp[x]);
        num[x]+=num[t];
    }
    return dp[x];
}
  1. dp[b]->dp[a]
  dp[v]=u;
    num[v]=num[a]+x-num[b];

在这里插入图片描述

AC代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int M=5e4+10;
int dp[M],num[M];
int f(int x)
{
    if(x!=dp[x])
    {
        int t=dp[x];
        dp[x]=f(dp[x]);/*因为在递归找祖先的过程中,dp[x]的值会改变,而我们我们只需要找到距离x最近的点,即可得到dp[x]到祖宗节点的距离。所以要记录t的值*/
        num[x]+=num[t];
    }
    return dp[x];
}
bool dfs(int a,int b,int x)
{
    int u=f(a),v=f(b);/*a->u,b->v*/
    if(u==v)
    {
        if(num[a]+x!=num[b])/*b->a,又起点为父节点*/
            return true;
        return false;
    }
    dp[v]=u;
    num[v]=num[a]+x-num[b];
    return false;
}
int main()
{
    int m,n;
    while(~scanf("%d%d",&m,&n))
    {
        int ans=0;
        for(int i=0;i<m;i++)
        {
            dp[i]=i;
            num[i]=0;
        }
        while(n--)
        {
            int a,b,x;/*设起点为祖宗节点,则都指向起点b->a*/
            scanf("%d%d%d",&a,&b,&x);
            if(dfs(a,b,x))
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值