题意:
给20个水碗。朝上为‘0’或朝下为‘1’,每次操作使三个碗翻转,问使所有20个水碗都朝上,至少翻多少次?
题目:
The cows have a line of 20 water bowls from which they drink. The bowls can be either right-side-up (properly oriented to serve refreshing cool water) or upside-down (a position which holds no water). They want all 20 water bowls to be right-side-up and thus use their wide snouts to flip bowls.
Their snouts, though, are so wide that they flip not only one bowl but also the bowls on either side of that bowl (a total of three or – in the case of either end bowl – two bowls).
Given the initial state of the bowls (1=undrinkable, 0=drinkable – it even looks like a bowl), what is the minimum number of bowl flips necessary to turn all the bowls right-side-up?
Input
Line 1: A single line with 20 space-separated integers
Output
Line 1: The minimum number of bowl flips necessary to flip all the bowls right-side-up (i.e., to 0). For the inputs given, it will always be possible to find some combination of flips that will manipulate the bowls to 20 0’s.
Sample Input
0 0 1 1 1 0 0 1 1 0 1 1 0 0 0 0 0 0 0 0
Sample Output
3
Hint
Explanation of the sample:
Flip bowls 4, 9, and 11 to make them all drinkable:
0 0 1 1 1 0 0 1 1 0 1 1 0 0 0 0 0 0 0 0 [initial state]
0 0 0 0 0 0 0 1 1 0 1 1 0 0 0 0 0 0 0 0 [after flipping bowl 4]
0 0 0 0 0 0 0 0 0 1 1 1 0 0 0 0 0 0 0 0 [after flipping bowl 9]
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 [after flipping bowl 11]
分析:
这个题直接暴力过得,直接正反遍历,找最小值,还有一种构造增广矩阵类似于根据开关的关系构造有向图的邻接矩阵;构造增广矩阵,高斯消元,枚举自由元(二进制枚举状态),寻找最小值的方法,因为时间关系就没有去钻研,在这提供下思路。
AC代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[30],b[30];
int ans,num;
int main(){
for(int i=1;i<=20;i++){
scanf("%d",&a[i]);
b[i]=a[i];
}
num=ans=0;
for(int i=1;i<=20;i++){
if(a[i]==1){
ans++;
a[i+1]=!a[i+1];
a[i+2]=!a[i+2];
}
}
for(int i=20;i>=1;i--){
if(b[i]==1){
num++;
b[i-1]=!b[i-1];
b[i-2]=!b[i-2];
}
}
ans=min(ans,num);
printf("%d\n",ans);
return 0;
}