PAT 甲级 1023. Have Fun with Numbers (20)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
#include<iostream>
#include<string>
#include<cstdio>
#include<vector>
#include<algorithm>
#include<queue>
#include <cmath>
#include <map>
#include <set>
#include <cstring>
using namespace std;

int book[10] = { 0 };
int main() {
	char num[22];
	int carry = 0;
	scanf("%s", num);
	int len = strlen(num);
	for (int i = len - 1; i >= 0; i--) {
		int temp = num[i] - '0';
		book[temp]++;
		temp = temp * 2 + carry;
		carry = temp / 10;
		num[i] = (temp % 10 + '0');
		book[temp % 10]--;
	}
	bool flag = false;
	for (int i = 0; i < 10; i++) {
		if (book[i] != 0)
			flag = true;
	}
	if (flag || carry == 1) {
		printf("No\n");
	}
	else {
		printf("Yes\n");
	}
	if (carry == 1)
		printf("1");
	printf("%s", num);
	return 0;
}

Yes
2469135798
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值