LQB 1D

Description

"How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?


Your program has to be efficient!

Input

Input consist several case,First line of the each case is an integer N ( 1 < N < 700 ),then follow N pairs of integers. Each pair of integers is separated by one blank and ended by a new-line character. The input ended by N=0.

Output

output one integer for each input case ,representing the largest number of points that all lie on one line.

Sample Input

5
1 1
2 2
3 3
9 10
10 11
0

Sample Output

3


#include<iostream> 
#include<cstdio>
#include<string.h>
#include<algorithm>
using namespace std;

int pos[750][5];

int main()
{
	int t,n;
	while(scanf("%d",&n)&&n!=0)
	{
		for(int i=1;i<=n;i++)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			pos[i][1]=a,pos[i][2]=b;
		}
		int ans=0;
		int Max=0;
		for(int i=1;i<=n;i++)
		{
			for(int j=i+1;j<=n;j++)
			{
				ans=2;
				for(int k=j+1;k<=n;k++)
				{
				
					int dx=(pos[j][2]-pos[i][2])*(pos[k][1]-pos[j][1]);
					int dy=(pos[k][2]-pos[j][2])*(pos[j][1]-pos[i][1]);
					if(dx==dy)
						ans++;		
					
				}
				
				Max=max(Max,ans);
			}
		}
		if(n==1) Max=1;
		if(n==2) Max=2;
		printf("%d\n",Max);
		
	}
	return 0;
}
暴力竟也能过
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值