南阳103 A+B Problem II

 
描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

 
输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.
样例输入
2
1 2
112233445566778899 998877665544332211
样例输出
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
    int t;
    int la,lb;
    int Case=1;
    scanf("%d",&t);
    while(t--)
    {
        int j,sum;
        char a[1100],b[1100];
        int an[1100]={0},bn[1100]={0};
        int ans[1100]={0};
        scanf("%s %s",a,b);
        la=strlen(a);
        lb=strlen(b);
        j=1;
        for(int i=la-1;i>=0;i--)
            an[j++]=a[i]-'0';
        j=1;
        for(int i=lb-1;i>=0;i--)
            bn[j++]=b[i]-'0';
        sum=0;
        j=1;
        for(int i=1;i<=((la>lb)?la:lb);i++)
        {
            sum+=an[i]+bn[i];
            ans[j++]=sum%10;
            sum/=10;
        }    
        ans[j]=sum;
        printf("Case %d:\n",Case++);
        printf("%s + %s = ",a,b);
        for(int i=((sum==0)?(j-1):j);i>=1;i--)
        {
            printf("%d",ans[i]);
        }
        printf("\n");
            
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值