OJ kruskal算法求最小生成树

总时间限制: 
10000ms
单个测试点时间限制: 
1000ms
内存限制: 
65536kB
描述

要求对一个图使用kruskal算法求最小生成树,依次输出选出的边所关联的顶点序列,要求下标较小者在前,如图所示,其顶点序列为1 3 4 6 2 5 3 6 2 3

输入
若干行整数
第一行为两个整数,分别为图的顶点数和边数
第二行开始是该图的邻接矩阵,主对角线统一用0表示,无直接路径的两点用100来表示(保证各边权值小于100)
输出
若干用空格隔开的整数
样例输入
6 10
0 6 1 5 100 100
6 0 5 100 3 100
1 5 0 5 6 4
5 100 5 0 100 2
100 3 6 100 0 6
100 100 4 2 6 0
样例输出
1 3 4 6 2 5 3 6 2 3


个人觉得prim算法比较好操作,kruskal算法理解了,但是,判断有没回环不知道砸门判断,所以就用prim算法做了

#include <iostream>
#include "cstring"
#include <stdio.h>
#include "iomanip"
#include "vector"
#include "cmath"
#include "stack"
#include "algorithm"
#include <math.h>
#include "map"
#include "queue"
#include "set"
using namespace std;
const int  INF=1<<30;
struct edge{
int start,end;
int w ;
edge(){}
edge(int a,int b,int c){start=a;end=b;w=c;}
bool operator <(const edge&bb)const{
return w>bb.w;
}
};
int main()
{
    freopen("a.txt","r",stdin);
    int n,v;
    cin>>n>>v;
    int Map[111][111]={0};
    int visit[111]={0};
    priority_queue <edge> q;
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
    {
        int a;
        cin>>a;
        Map[i][j]=a;
    }
    visit[1]=1;
    for(int k=0;k<n-1;k++)
    {
        int mini=INF;
        int end=0,start=0;
        for(int i=1;i<=n;i++)
        {
            if(visit[i]==1)
            {
                for(int j=1;j<=n;j++)
                {
                    if(Map[i][j]!=0&&Map[i][j]!=100)
                    if(mini>Map[i][j]&&visit[j]==0)
                    {
                        mini=Map[i][j];
                        end=j;
                        start=i;
                    }
                }
            }
        }
        visit[end]=1;
        q.push(edge(start,end,mini));
    }
    while (!q.empty())
    {
        edge t=q.top();
        q.pop();
        int a=t.start;
        int b=t.end;
        int a1=max(a,b);
        int b1=min(a,b);
        cout<<b1<<" "<<a1<<" ";
    }
    return 0;
}

///kruskal算法实现

#include <iostream>
#include "cstring"
#include <stdio.h>
#include "iomanip"
#include "vector"
#include "cmath"
#include "stack"
#include "algorithm"
#include <math.h>
#include "map"
#include "queue"
#include "set"
using namespace std;
const int  INF=1<<30;
struct edge{
int start,end;
int w ;
edge(){}
edge(int a,int b,int c){start=min(a,b);end=max(a,b);w=c;}
bool operator <(const edge&bb)const{
return w>bb.w;
}
};
int f[1111]={0};
int r[1111]={0};
int find(int a)
{
    if(a==f[a])
        return a;
    return f[a]=find(f[a]);
}
bool  abc(int a,int b)
{
    int x=find(a);
    int y=find(b);
    if(x==y)
        return false;
    if(r[x]>=r[y])
    {
        f[y]=x;
        r[x]++;
    }
    else
    {
        f[x]=y;
        r[y]++;
    }
    return true;
}
int main()
{
    freopen("a.txt","r",stdin);
    int n,v;
    cin>>n>>v;
    int visit[111]={0};
    priority_queue <edge> q;
    vector <edge> res;
    for(int i=1;i<=n;i++)
    {
        f[i]=i;
        for(int j=1;j<=n;j++)
        {
            int a;
            cin>>a;
            if(a!=0&&a!=100)
            {
                q.push(edge(i,j,a));
            }
        }
    }
    while(res.size()!=n-1)
    {
        edge t=q.top();
        q.pop();
        int start=t.start;
        int end=t.end;
        if(abc(start,end))
        {
            res.push_back(t);
        }
    }
    for(int i=0;i<n-1;i++)
        cout<<res[i].start<<" "<<res[i].end<<" ";
    return 0;
}

评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值