POJ1523(tarjan割点后,连通分量有多少)

SPF
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9693 Accepted: 4365
Description


Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible. 


Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate. 


Input


The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.
Output


For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist. 


The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.
Sample Input


1 2
5 4
3 1
3 2
3 4
3 5
0


1 2
2 3
3 4
4 5
5 1
0


1 2
2 3
3 4
4 6
6 3
2 5
5 1
0


0
Sample Output


Network #1
  SPF node 3 leaves 2 subnets


Network #2
  No SPF nodes


Network #3
  SPF node 2 leaves 2 subnets

  SPF node 3 leaves 2 subnets

题意就是求下割点,求过割点后,删除一个割点后两桶分量有几个。求个点我在以前博客里写过了,代码上关于割点后得到连通分量的注释

//去掉一个割点后,根节点特殊,他的所有子树都是一个连通分量,而其他割点
//大家想其他节点是怎么求的,通过看dfn[v]是不是小于等于low[u],如果小于等于就代表v必须经过u,那么u把图分成了两部分
//以v未根节点的树和u上边的祖先的那一部分,那么我们求得dfn[v]<=low[u]以后就aa[u]++,求u下边的那一部分,最后加1(祖先那一部分)就是割点后的连通分量
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
    int to;
    int next;
} e[100005];
int r,cnt,sum;
int first[10005],dfn[10005],low[100005],aa[100005];
void init()
{
    memset(first,-1,sizeof(first));
    memset(dfn,0,sizeof(dfn));
    memset(low,0,sizeof(low));
    memset(aa,0,sizeof(aa));
    r=0;
    cnt=1;
    sum=0;
}
void add(int u,int v)
{
    e[r].to=v;
    e[r].next=first[u];
    first[u]=r++;
}
void tarjan(int u,int from)
{
    dfn[u]=low[u]=cnt++;
    for(int i=first[u]; i!=-1; i=e[i].next)
    {
        int v=e[i].to;
        if(dfn[v]==0)
        {
            tarjan(v,u);
            low[u]=min(low[u],low[v]);
            if(u==1)
            {
                sum++;
            }
            else if(low[v]>=dfn[u])//得到除了根节点以外的割点
            {
                aa[u]++;
            }
        }
        else if(v!=from)
            low[u]=min(low[u],dfn[v]);
    }
}
int main()
{
    int t=1;
    while(1)
    {
        init();
        int u;
        int maxx=-1;
        scanf("%d",&u);
        if(u==0)
            break;
        int v;
        scanf("%d",&v);
        if(u>maxx) maxx=u;
        if(v>maxx) maxx=v;
        add(u,v);
        add(v,u);
        while(1)
        {
            scanf("%d",&u);
            if(u==0) break;
            scanf("%d",&v);
            if(u>maxx) maxx=u;
            if(v>maxx) maxx=v;
            add(u,v);
            add(v,u);
        }
        if(t>1)
            printf("\n");
        printf("Network #%d\n", t++);
        tarjan(1,-1);
        if(sum>1) aa[1]=sum-1;//特判根节点为割点情况
        int flag=0;
        for(int i=1; i<=maxx; i++)
        {
            if(aa[i])
            {
                flag=1;
                printf("  SPF node %d leaves %d subnets\n",i,aa[i]+1);
            }
        }
        if(!flag) printf("  No SPF nodes\n");
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值