Nightmare HDU - 1072

Nightmare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13745    Accepted Submission(s): 6655

 

Problem Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

Sample Input 

3

3 3

2 1 1

1 1 0

1 1 3

4 8

2 1 1 0 1 1 1 0

1 0 4 1 1 0 4 1

1 0 0 0 0 0 0 1

1 1 1 4 1 1 1 3

5 8

1 2 1 1 1 1 1 4

1 0 0 0 1 0 0 1

1 4 1 0 1 1 0 1

1 0 0 0 0 3 0 1

1 1 4 1 1 1 1 1

Sample Output

4

-1

13

题意:现在有个炸弹,你要把他从你的初始位置带到终点位置,能带去的话就输出最小步数,不能的话就输出-1。给出一张n*m的地图,地图由0,1,2,3,4组成,0代表墙,1代表路,2代表人所在的地方,3代表目的地,4代表炸弹时间重置器。我们从2出发,走到3,炸弹时间有6就炸,人走动一次 花费1,但是走到4就会重置时间。只要在时间不为0走到3就算成功。

这道题表示可以重复走,那么就不能乱加标记,并且要求的值最小步数,我们知道广搜是同时搜索,谁先找到社就是最小,相对于深搜广搜更合适,但是有个点需要注意,4代表的时间重置器不能乱走动,因为可以重复走,但是我们每次都回到4再出发肯定是浪费时间的,那么我们每次走到4就把4变成0这样就避免了这种尴尬的情况

#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
using namespace std;
int a,b;
struct node
{
    int x,y,step,time;
};
int mapp[10][10];
int dx[4]={0,1,0,-1},dy[4]={1,0,-1,0};
node st,ed;
int judge(int x,int y,int time)
{
    if(x>=0&&x<a&&y>=0&&y<b&&time>0&&mapp[x][y]!=0)
        return 1;
    return 0;
}
int bfs()
{
    queue<node>q;
    while(!q.empty()) q.pop();
    q.push(st);
    while(!q.empty())
    {
        st=q.front();
        q.pop();
        for(int i=0;i<4;i++)
        {
            ed.x=st.x+dx[i];
            ed.y=st.y+dy[i];
            ed.step=st.step+1;
            ed.time=st.time-1;
            if(judge(ed.x,ed.y,ed.time))
            {
                if(mapp[ed.x][ed.y]==3)
                    return ed.step;
                if(mapp[ed.x][ed.y]==4)
                    ed.time=6,mapp[ed.x][ed.y]=0;
                q.push(ed);
            }
        }
    }
    return -1;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&a,&b);
        for(int i=0; i<a; i++)
            for(int j=0; j<b; j++)
            {
                scanf("%d",&mapp[i][j]);
                if(mapp[i][j]==2)
                {
                    st.x=i;
                    st.y=j;
                    st.step=0;
                    st.time=6;
                }
            }
        printf("%d\n",bfs());
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值