HDU3530 Subsequence

Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8707    Accepted Submission(s): 2928


 

Problem Description

There is a sequence of integers. Your task is to find the longest subsequence that satisfies the following condition: the difference between the maximum element and the minimum element of the subsequence is no smaller than m and no larger than k.

 

 

Input

There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range [1, 100000]. m and k are in the range [0, 1000000]. The second line has n integers, which are all in the range [0, 1000000].
Proceed to the end of file.

 

 

Output

For each test case, print the length of the subsequence on a single line.

 

 

Sample Input

5 0 0
1 1 1 1 1
5 0 3
1 2 3 4 5

Sample Output

 

5

4

 

题意:就是给你一个串,要求求出当前串最大值减最小值大于等于m小于等于k的最长长度

第一次看这个不是很懂,当初刚学单调队列,不是很懂,就放一放,这次看还行,懂了。我们要求在符合条件下的最长长度,单调队列就是可以求得一个序列最小,最大值,那我们每次对比最大最小值是否符合条件,大于k时要求出来靠前一位的是最大还是最小值,当最大最小差值大于k那就不符合条件了,这时那个靠前的最值之前的都不符合,只能在这个最值的下一位以后的序列里找符合题意的长度。所以now就是记录那个最值的后一位。

#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=100005;
int a[maxn],q1[maxn],q2[maxn];
int main()
{
    int n,m,k;
    while(~scanf("%d%d%d",&n,&m,&k))
    {
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        int head1=0,head2=0,tail1=0,tail2=0,now=0,ans=0;
        for(int i=0; i<n; i++)
        {
            while(head1<tail1&&a[q1[tail1-1]]<a[i])
                tail1--;
            while(head2<tail2&&a[q2[tail2-1]]>a[i])
                tail2--;
            q1[tail1++]=q2[tail2++]=i;
            while(head1<tail1&&head2<tail2&&a[q1[head1]]-a[q2[head2]]>k)
            {
                if(q1[head1]<q2[head2])
                    now=q1[head1++]+1;
                else
                    now=q2[head2++]+1;
            }
            if(head1<tail1&&head2<tail2&&a[q1[head1]]-a[q2[head2]]>=m)
                ans=max(ans,i-now+1);
        }
        printf("%d\n",ans);
    }
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值