HDU 1020 Encoding

6 篇文章 0 订阅
5 篇文章 0 订阅
Encoding
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

 

Description

Given a string containing only 'A' - 'Z', we could encode it using the following method:  

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.  

2. If the length of the sub-string is 1, '1' should be ignored.  
 

Input

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.  
 

Output

For each test case, output the encoded string in a line.  
 

Sample Input

     
     
2 ABC ABBCCC
 

Sample Output

     
     
ABC A2B3C
 

分析

简单的暴力,直接遍历一边输出结果即可,注意cnt==1时的特殊输出。

 

AC代码如下:

#include <cstdio>
#include <cstring>
using namespace std;

int main()
{
    int t,i,cnt;
    char ch[10005];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",ch);
        for(i = 0; ch[i]!='\0';)
        {
            cnt = 1;
            while(ch[i] == ch[i+1])              //计算重复次数
            {
                cnt++;
                i++;
            }
            if(cnt == 1) printf("%c",ch[i]);     //等于1的时候特殊处理
            else printf("%d%c",cnt,ch[i]);
            i++;
        }
        printf("\n");
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值