UVA11729 Commando War

Commando War
Time Limit:1000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

“Waiting for orders we held in the wood, word from the front never came
By evening the sound of the gun re was miles away
Ah softly we moved through the shadows, slip away through the trees
Crossing their lines in the mists in the elds on our hands and our knees
And all that I ever, was able to see
The re in the air, glowing red, silhouetting the smoke on the breeze”


There is a war and it doesn't look very promising for your country. Now it's time to act. You have a commando squad at your disposal and planning an ambush on an important enemy camp located nearby. You have N soldiers in your squad. In your master-plan, every single soldier has a unique responsibility and you don't want any of your soldier to know the plan for other soldiers so that everyone can focus on his task only. In order to enforce this, you brief every individual soldier about his tasks separately and just before sending him to the battle eld. You know that every single soldier needs a certain amount of time to execute his job. You also know very clearly how much time you
need to brief every single soldier. Being anxious to nish the total operation as soon as possible, you need to nd an order of brie ng your soldiers that will minimize the time necessary for all the soldiers to complete their tasks. You may assume that, no soldier has a plan that depends on the tasks of his fellows. In other words, once a soldier begins a task, he can nish it without the necessity of pausing in between.

Input
There will be multiple test cases in the input le. Every test case starts with an integer N (1 <= N <= 1000), denoting the number of soldiers. Each of the following N lines describe a soldier with two integers B (1 <= B <= 10000) & J (1 <= J <= 10000). B seconds are needed to brief the soldier while completing his job needs J seconds. The end of input will be denoted by a case with N = 0. This case should not be processed.
Output
For each test case, print a line in the format, `Case X: Y ', where X is the case number & Y is the total number of seconds counted from the start of your rst brie ng till the completion of all jobs.
Sample Input
3
2 5
3 2
2 1
3
3 3
4 4
5 5
0

Sample Output
Case 1: 8
Case 2: 15

题意
将军给每个人单独的任务。交代任务时间为 ai ,完成任务时间为 bi ,给一个人交代完任务后,就可以继续给下一个人交代任务,不同人之间的任务互不影响,即可以多个人同时工作结束时间以最后以一个人为准,问最少需要多长时间可以完成所有任务。

分析
最先让完成任务时间长的人工作,在他工作时给别的人交代工作,就能够保证时间最短。以完成任务的时间长短降序排序,记 t2 = ai + bi ,hw = bi-1 若 t2 > hw ,则总时间 +ai,hw = bi,否则总时间 +ai ,hw -= bi 。

AC代码如下

#include <cstdio>
#include <algorithm>
#define maxn 1000+2

using namespace std;
struct soldier
{
    int t,w;
};

bool cmp(soldier a, soldier b)
{
    return a.w > b.w;
}

soldier s[maxn];
int main()
{
    int n,cas = 0;
    while(~scanf("%d",&n) && n)
    {
        for(int i = 0 ; i < n; i++)
            scanf("%d%d",&s[i].t,&s[i].w);
        sort(s,s+n,cmp);<span style="white-space:pre">			</span>//以工作时间降序排序
        int sum = 0;
        int hw = s[0].w;
        sum += s[0].t;
        for(int i = 1 ; i < n; i++)<span style="white-space:pre">		</span>//判断并更新总时间
        {
            int t2 = s[i].t + s[i].w;
            if(t2 > hw)
            {
                sum += s[i].t;
                hw = s[i].w;
            }
            else
            {
                sum += s[i].t;
                hw -= s[i].t;
            }
        }
        sum += hw;
        printf("Case %d: %d\n",++cas,sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值