1932: Dinner

                                              1932: Dinner

                                                     时间限制: 100 Sec  内存限制: 64 MB
 

题目描述

Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball" is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.

输入

There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.

输出

For each test of the input, output all the name of tableware.

样例输入

3 basketball fork chopsticks
2 bowl letter

样例输出

fork chopsticks
bowl

 

代码一:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>//比较两个字符串。设这两个字符串为str1,str2,若str1==str2,则返回零;若str1>str2,则返回正数;若str1<str2,则返回负数。

当且仅当str和str2相等时,结果为0
!strcmp(str,str2)是相当于结果不为0,所以就是两个字符串不相等的意思
当两个字符串不相等时if成立。

char str[100][100];
int main()
{
	int n,i;
	while(scanf("%d",&n)!=EOF)
	{

		for(i=0;i<n;i++)
	        scanf("%s",str[i]);
	    int k=0;
	    for(i=0;i<n;i++)
	    {
		     if(strcmp(str[i],"bowl")==0||strcmp(str[i],"knife")==0||strcmp(str[i],"fork")==0||strcmp(str[i],"chopsticks")==0)

		     {
		     	if(k==0)
		     	  printf("%s",str[i]);
		     	else printf(" %s",str[i]);
		     	k++; 
		     }
	}
	    printf("\n");

	}
	return 0;

} 

代码二:

 

#include<stdio.h>
#include<string.h>
 int main()
 {
 int n;
 while(scanf("%d",&n)!=EOF)
 {
 getchar();
 char a[n][100];
 char b[]="chopsticks";
 char c[]="fork";
 char d[]="bowl";
 int len[n];
 int m[n];
 for(int i=0;i<n;i++)
 {
 m[i]=0;
 }
 for(int i=0;i<n;i++)
 {
 scanf("%s",&a[i]);
 }
 for(int i=0;i<n;i++)
 len[i]=strlen(a[i]);
 for(int i=0;i<n;i++)
 {
 for(int j=0;j<len[i];j++)
 {
 if(a[i][j]==b[j]||a[i][j]==c[j]||a[i][j]==d[j])
 m[i]++;
 else break;
 }
 }
 for(int i=0;i<n;i++)
 {
 if(len[i]==m[i])
 printf("%s ",a[i]);
 }
 printf("\n");
 }
 return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值