PAT甲级真题 1061 Dating (20分) C++实现(同乙级1014,使用cctype)

题目

Sherlock Holmes received a note with some strange strings: Let’s date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 – since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:
Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:
For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week – that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:

3485djDkxh4hhGE 
2984akDfkkkkggEdsb 
s&hgsfdk 
d&Hyscvnm

Sample Output:

THU 14:04

思路

PAT乙级真题 1014 福尔摩斯的约会是同一道题,没想到又栽倒了同一个坑上…

不过代码比以前写的聪明了些,使用cctype.h判断字符串类型十分方便。

坑点

测试点2、4考察的是要做合法性测试,即代表星期几的大写字母需要在[A-G]内,代表小时的大写字母需要在[A-N]内。

挺没意思的…题目应该再表述清晰些或提供相应样例。

代码

#include <iostream>
#include <cctype>
using namespace std;

const string day[] = {"MON", "TUE", "WED", "THU", "FRI", "SAT", "SUN"};
int main(){
    string s1, s2, s3, s4;
    cin >> s1 >> s2 >> s3 >> s4;
    int i = 0;
    while (i<s1.size()){
        if (s1[i]==s2[i] && isupper(s1[i]) && s1[i]<='G'){
            cout << day[s1[i]-'A'] << " ";
            break;
        }
        i++;
    }
    i++;
    while (i<s1.size()){
        if (s1[i]==s2[i]){
            if (isupper(s1[i]) && s1[i]<='N'){
                printf("%02d:", s1[i] - 'A' + 10);
                break;
            }
            else if (isdigit(s1[i])){
                printf("%02d:", s1[i] - '0');
                break;
            }
        }
        i++;
    }
    for (i=0; i<s3.size(); i++){
        if (s3[i]==s4[i] && isalpha(s3[i])){
            printf("%02d", i);
            break;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值