PAT甲级真题 1086 Tree Traversals Again (25分) C++实现(由先序、中序求后序)

该博客主要解析PAT甲级真题1086,讨论如何通过非递归方式实现二叉树的中序遍历,并基于给定的先序和中序遍历序列,推导后序遍历序列。内容包括问题描述、解题思路、相关代码以及扩展知识,如如何由后序和中序序列求先序和层序序列。
摘要由CSDN通过智能技术生成

题目

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

在这里插入图片描述
Figure 1

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

思路

节点的入栈顺序是先序序列,出栈顺序是中序序列,题目可转换为已知先序、中序求后序。

先序+中序求后序的代码如下(参考柳神代码):

#include <cstdio>
using namespace std;
int pre[] = {1, 2, 3, 4, 5, 6};
int in[] = {3, 2, 4, 1, 6, 5};
void post(int root, int start, int end) {
    if(start > end) 
        return ;
    int i = start;
    while(i < end && in[i] != pre[root]) i++;
    post(root + 1, start, i - 1);
    post(root + 1 + i - start, i + 1, end);
    printf("%d ", pre[root]);
}
 
int main() {
    post(0, 0, 5);
    return 0;
}

//打印结果为:3, 4, 2, 6, 5, 1(左右根)

用root表示根节点在pre中的下标(因为pre序列只提供根节点信息,确定root位置即可), start、end表示in中的左右边界的下标(start、end确定左右子树中的一个)。

扩展知识

由后序+中序求先序的代码如下:

#include <cstdio>
using namespace std;
int post[] = {3, 4, 2, 6, 5, 1};
int in[] = {3, 2, 4, 1, 6, 5};
void pre(int root, int start, int end) {
    if(start > end) return ;
    int i = start;
    while(i < end && in[i] != post[root]) i++;
    printf("%d ", post[root]);
    pre(root - 1 - end + i, start, i - 1);
    pre(root - 1, i + 1, end);
}
 
int main() {
    pre(5, 0, 5);
    return 0;
}
//打印结果为:1, 2, 3, 4, 5, 6(根左右)

由后序+中序求层序的代码如下(利用了map会根据index从小到大自动排序):


#include <cstdio>
#include <vector>
#include <map>
using namespace std;
vector<int> post, in;
map<int, int> level;
void pre(int root, int start, int end, int index) {
    if(start > end) return ;
    int i = start;
    while(i < end && in[i] != post[root]) i++;
    level[index] = post[root];
    pre(root - 1 - end + i, start, i - 1, 2 * index + 1);
    pre(root - 1, i + 1, end, 2 * index + 2);
}
int main() {
    int n;
    scanf("%d", &n);
    post.resize(n);
    in.resize(n);
    for(int i = 0; i < n; i++) scanf("%d", &post[i]);
    for(int i = 0; i < n; i++) scanf("%d", &in[i]);
    pre(n-1, 0, n-1, 0);
    auto it = level.begin();
    printf("%d", it->second);
    while(++it != level.end()) printf(" %d", it->second);
    return 0;
}

Tips:中序+先序/后序/层序中任意一个,都能确定唯一的二叉树。后三者两两搭配或者三个一起都无法确定唯一的二叉树,因为它们都只是提供了根节点信息,只有中序序列才能区分左右子树。

代码

#include <iostream>
#include <vector>
#include <stack>
using namespace std;

vector<int> pre;
vector<int> in;
vector<int> post;

//已知pre、in,求post
//root为根在pre中的下标, left、right为in中的左右边界
void Post(int root, int left, int right){
    if (left > right) return;
    //定位in数组中根的位置,存储到i中
    int i = left;
    while(i<right && in[i]!=pre[root]) i++;
    Post(root+1, left, i-1);
    Post(root+1+i-left, i+1, right);
    post.push_back(pre[root]);
}

int main(){
    int n;
    cin >> n;

    stack<int> ss;

    string cmd;
    for (int i=0; i<2*n; i++){
        int k;
        cin >> cmd;
        if (cmd=="Push"){
            cin >> k;
            ss.push(k);
            pre.push_back(k);
        }
        else{
            in.push_back(ss.top());
            ss.pop();
        }
    }

    Post(0, 0, n-1);
    
    cout << post[0];
    for (int i=1; i<n; i++){
        cout << " " << post[i];
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值