PAT甲级真题 1102 Invert a Binary Tree (25分) C++实现(找树根,层序、中序遍历翻转二叉树)

题目

The following is from Max Howell @twitter:
Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.
Now it’s your turn to prove that YOU CAN invert a binary tree!
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.
Output Specification:
For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

思路

用vector模拟存储树,通过左右孩子的下标确定左右子树位置。

翻转二叉树十分简单,存储的时候把左右孩子交换即可。

但题目没有给根的位置,需要把它找出来。因为根不是任何节点的孩子,所以只要找出没有在左、右孩子序号中出现过的节点即为根。

有了根后分别层序、中序遍历即可。

代码

#include <iostream>
#include <vector>
#include <queue>
using namespace std;

struct Node{
    int l, r;
};

void printArray(vector<int> res){
    cout << res[0];
    for (int i=1; i<res.size(); i++) 
        cout << " " << res[i];
    cout << endl;
}

void levelOrder(vector<Node> &a, int root, vector<int> &res){
    queue<int> que;
    que.push(root);
    while (!que.empty()){
        int cur = que.front();
        que.pop();
        res.push_back(cur);
        if (a[cur].l != -1) que.push(a[cur].l);
        if (a[cur].r != -1) que.push(a[cur].r);
    }
}

void inOrder(vector<Node> &a, int root, vector<int> &res){
    if (a[root].l != -1) inOrder(a, a[root].l, res);
    res.push_back(root);
    if (a[root].r != -1) inOrder(a, a[root].r, res);
}

int main() {
    int n;
    cin >> n;
    vector<Node> a(n);
    vector<bool> exist(n);
    char l, r;
    for (int i=0; i<n; i++){
        cin >> r >> l;
        if (r!='-') {
            a[i].r = r - '0'; 
            exist[a[i].r] = true;
        }
        else{
            a[i].r = -1;
        }
        if (l!='-') {
            a[i].l = l - '0'; 
            exist[a[i].l] = true;
        }
        else{
            a[i].l = -1;
        }
    }

    int root = 0;
    while (exist[root]) root++;

    vector<int> res;
    levelOrder(a, root, res);
    printArray(res);

    res.clear();
    inOrder(a, root, res);
    printArray(res);

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值