1205:ASCLL码排序

1205:ASCLL码排序


Description


输入三个字符(可以重复)后,按各字符的ASCLL码从小到大的顺序输出这三个字符。


Input


第一行输入一个数N,表示有N组测试数据,后面的N行输入多组数据,每组输入数据都是占一行,有三个字符组成,之间无空格。


Output


对于每组输入数据,输出一行,字符中间用一个空格分开。


Sample Input


3

qwe

asd

zxc


Sample Output


e  q  w

a  s  d

c  x   z


#include<iostream>
#include<string>
using namespace std;
int main()
{
    int N,i,j;
    string ch;
    cin>>N;
while(N--)
    {
    cin>>ch;
    int temp,index,k;
   for(k=0;k<2;k++)
   {
   index=k;
    for(j=k+1;j<3;j++)
    {
       if(ch[j]<ch[index])
        {
            index=j;
        }
    }
    if(index!=k)
    {
        temp=ch[k];ch[k]=ch[index];ch[index]=temp;
    }
 
    }
   cout<<ch[0];
   for(i=1;i<3;i++)
   {
       cout<<" "<<ch[i];
   }
cout<<endl;
    }
return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值