Poj-Layout

题目名称:Layout

题目链接:Layout

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1…N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD.

Lines 2…ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2…ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

题目大意

有ml头牛是好友,他们之间的距离不超错c,有md头牛不是好友,他们之间的距离最少为c,请问符合条件的从1-N的最短距离

解题思路

简单的差分约束模板题,方程式如下:

c o w 1 − c o w 3 ≤ 10 cow_1-cow_3 \leq10 cow1cow310
c o w 2 − c o w 4 ≤ 20 cow_2-cow_4\leq20 cow2cow420
c o w 2 − c o w 3 ≥ 3 cow_2-cow_3\geq3 cow2cow33
将第三个式子两边乘-1
c o w 3 − c o w 2 ≤ 3 cow_3-cow_2\leq3 cow3cow23

完整代码

采用kuangbin的模板,确实方便易懂

#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<cstring>
using namespace std;

const int N=1010;
const int inf=0x3f3f3f3f;
bool vis[N];
int cnt[N];
int dist[N];
struct edge{
	int v,cost;
	edge(int _v=0,int _cost=0):v(_v),cost(_cost){}
};
vector<edge> E[N];

void addedge(int u,int v,int w){
	E[u].push_back(edge(v,w));
} 

bool spfa(int s,int n){
	memset(vis,0,sizeof(vis));
	memset(dist,0x3f,sizeof(dist));
	vis[s]=true;
	dist[s]=0;
	queue<int>que;
	while(!que.empty()) que.pop();
	
	que.push(s);
	memset(cnt,0,sizeof(cnt));
	cnt[s]=1;
	while(!que.empty()){
		int u=que.front();
		que.pop();
		vis[u]=false;
		for(int i=0;i<E[u].size();i++){
			int v=E[u][i].v;
			if(dist[v]>dist[u]+E[u][i].cost){
				dist[v]=dist[u]+E[u][i].cost;
				if(!vis[v]){
					que.push(v);
					vis[v]=true;
					if(++cnt[v]>n) return false;
				}
			}
		}
	}
	return true;
}

int main()
{
	int n,ml,md;
	int a,b,c;
	while(cin>>n>>ml>>md){
		while(ml--){
			cin>>a>>b>>c;
			addedge(a,b,c);
		}
		while(md--){
			cin>>a>>b>>c;
			addedge(b,a,-c);
		}
		if(!spfa(1,n)) cout<<"-1\n";
		else if(dist[n]==inf) cout<<"-2\n";
		else cout<<dist[n]<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值