poj1961 Period(kmp)

Period

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.
Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input

3
aaa
12
aabaabaabaab
0
Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题意:如果一个字符串S是由一个字符串T重复K次形成的,则T为S的循环元。使K最大的字符串T为S的最小循环元,此时K称为最大循环次数。给定一个字符串S,求S的每个前缀的最大循环次数,若最大循环次数大于1,输出此时前缀长度和最大循环次数。

分析:根据kmp中next数组的定义,显然当i%(i - next[i])=0时,1~i-next[i]就是前缀i的最小循环元,解决问题。

代码

#include <cstdio>
#include <string>
#include <cstring>
#define N 1000005
using namespace std;

char s[N];
int next[N],n;

int main()
{
    int cnt = 0;
    while(~scanf("%d", &n))
    {
        if (!n) break;
        scanf("%s", s+1);
        printf("Test case #%d\n", ++cnt);
        int k = 0;
        for (int i = 2; i <= n; i++)
        {
            while(k && s[k + 1] != s[i]) k = next[k];
            if (s[k + 1] == s[i]) k++;
            next[i] = k;
            if (i - k == 0) continue;
            if (i % (i - k) == 0 && k) printf("%d %d\n", i, i / (i - k));
        }
        printf("\n");
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值