题目表述:
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)
Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:
1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.
2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.
输入:
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
输出:
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
样例输入:
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4
样例输出:
Not sure yet.
In different gangs.
In the same gang.
大体题意就是,当是D的时候说明两个人不是同一个帮派的,当是A的时候自己判断。思路和食物链差不多,建立一个2*n的数组,代表两个帮派。理解代码的时候一定要自己动手把例子写出来,顺着代码走一遍,就比较好理解了
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define maxn 200500
int q[maxn];
int FIND(int x)
{
if(q[x]==x)
return x;
return q[x]=FIND(q[x]);
}
bool same(int x,int y)
{
return FIND(x)==FIND(y);
}
void combine(int x,int y)
{
int xx=FIND(x);
int yy=FIND(y);
if(xx!=yy)
q[yy]=xx;
}
int main()
{
int t,n,m,a,b;
char s;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for(int i=1;i<=2*n;i++)
{
q[i]=i;
}
for(int i=1;i<=m;i++)
{
getchar();
scanf("%c%d%d",&s,&a,&b);
if(s=='D')
{
if(!same(a,b+n)&&!same(a+n,b))//当a,b不一个帮派是,将a,b+n(或者a+n,b)组合起来,因为他们是同类
{
combine(a,b+n);
combine(a+n,b);
}
}
else if(s=='A')
{
if(same(a,b)||same(a+n,b+n))
printf("In the same gang.\n");
else if (same(a,b+n)||same(a+n,b))
printf("In different gangs.\n");
else
printf("Not sure yet.\n");
}
}
}
return 0;
}