Dining 最大流拆点

题目:

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

输入:

Line 1: Three space-separated integers: NF, andD 
Lines 2.. N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cowi likes and the number of drinks that cow ilikes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.

输出:

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

样例输入:

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

样例输出:

3

题意:一共有N头奶牛,F中食物,D种饮料。每头奶牛要吃到自己喜欢的食物和饮料,并且食物和饮料必须是一个类型的,比如它吃了1类型的食物,就必须喝1类型的饮料。只有吃的食物和饮料都是自己喜欢的,它才会高兴。求最多有几头奶牛会高兴。输入的数首先是N,F,D,然后接下来的每一行的前两个数Fi,Di分别表示这头牛喜欢的食物和饮料的种类,然后接下来的Fi个数是这头牛喜欢的具体类型,后面Di个数表示这头牛喜欢的饮料的类型。

思路:要把奶牛拆成两个点。因为如果不拆开的话,一头牛可能会贪吃(吃多种类型的食物和饮料,从而让别的牛吃不着东西),借用一下别人的图来理解一下。

1.当牛不拆开的情况

1通过4到5之后,2还可以通过4到6,造成一头牛贪吃

2.当牛拆开的时候

 

1通过4通过8到5,之后,4到8这条路已经没有流量了,所以不能再走了,所以就避免了一头牛吃多种食物的情况

牛1是从1到n,牛2是从1+N到2N,食物是从2N+1到2N+F,饮料是从2N+F+1到2N+F+D,超级源点是0,超级汇点是2N+F+D+1

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <algorithm>
using namespace std;
const int maxn=2000;//开太小会runti error
const int INF=0x3f3f3f3f;
int cnt,n,f,d;
int s,T;
int head[maxn],dis[maxn],cur[maxn];
struct edge
{
    int u,v,c,next;
}node[maxn*2];
void add(int u,int v,int c)
{
    node[cnt].u=u;
    node[cnt].v=v;
    node[cnt].c=c;
    node[cnt].next=head[u];
    head[u]=cnt++;
}
bool bfs()
{
    memset(dis,0,sizeof(dis));
    queue<int>q;
    dis[s]=1;
    q.push(s);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        for(int i=head[u];i!=-1;i=node[i].next)
        {
            edge e=node[i];
            if(!dis[e.v]&&e.c>0)
            {
                dis[e.v]=dis[e.u]+1;
                q.push(e.v);
                if(e.v==T)return 1;
            }
        }
    }
    return dis[T]!=0;
}
int dfs(int u,int mx)
{
    int ret=0;
    if(u==T || mx==0) return mx;
    for(int &i=cur[u];i!=-1;i=node[i].next)
    {
        edge e=node[i];
        if(dis[e.v]==dis[e.u]+1&&e.c>0)
        {
            int w=dfs(e.v,min(mx,e.c));
            node[i].c-=w;
            node[i^1].c+=w;
            ret+=w;
            mx-=w;
            if(mx==0) break;
        }
    }
    return ret;
}
int dinic()
{
    int maxflow=0;
    while(bfs())
    {
        memcpy(cur,head,sizeof(head));
        maxflow+=dfs(s,INF);
    }
    return maxflow;
}
int main()
{

    while(~scanf("%d%d%d",&n,&f,&d))
    {
        int ff,dd;
    T=2*n+f+d+1;
    s=0;
     memset(head,-1,sizeof(head));
    cnt=0;
    for(int i=1;i<=n;i++)
    {
        scanf("%d%d",&ff,&dd);
        for(int j=1;j<=ff;j++)
        {
            int fi;
            scanf("%d",&fi);//食物和牛1连接
            add(2*n+fi,i,1);
            add(i,2*n+fi,0);
        }
        for(int j=1;j<=dd;j++)//牛2和饮料连接
        {
            int di;
            scanf("%d",&di);
            add(n+i,2*n+f+di,1);
            add(2*n+f+di,n+i,0);
        }
        add(i,i+n,1);//牛1和牛2连接
        add(i+n,i,0);
    }
    for(int j=1;j<=f;j++)//超级源点和食物连接
    {
        add(0,2*n+j,1);
        add(2*n+j,0,0);
    }
    for(int j=1;j<=d;j++)//超级汇点和饮料连接
    {
        add(2*n+f+j,T,1);
        add(T,2*n+f+j,0);
    }
    printf("%d\n",dinic());
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
完整版:https://download.csdn.net/download/qq_27595745/89522468 【课程大纲】 1-1 什么是java 1-2 认识java语言 1-3 java平台的体系结构 1-4 java SE环境安装和配置 2-1 java程序简介 2-2 计算机中的程序 2-3 java程序 2-4 java类库组织结构和文档 2-5 java虚拟机简介 2-6 java的垃圾回收器 2-7 java上机练习 3-1 java语言基础入门 3-2 数据的分类 3-3 标识符、关键字和常量 3-4 运算符 3-5 表达式 3-6 顺序结构和选择结构 3-7 循环语句 3-8 跳转语句 3-9 MyEclipse工具介绍 3-10 java基础知识章节练习 4-1 一维数组 4-2 数组应用 4-3 多维数组 4-4 排序算法 4-5 增强for循环 4-6 数组和排序算法章节练习 5-0 抽象和封装 5-1 面向过程的设计思想 5-2 面向对象的设计思想 5-3 抽象 5-4 封装 5-5 属性 5-6 方法的定义 5-7 this关键字 5-8 javaBean 5-9 包 package 5-10 抽象和封装章节练习 6-0 继承和多态 6-1 继承 6-2 object类 6-3 多态 6-4 访问修饰符 6-5 static修饰符 6-6 final修饰符 6-7 abstract修饰符 6-8 接口 6-9 继承和多态 章节练习 7-1 面向对象的分析与设计简介 7-2 对象模型建立 7-3 类之间的关系 7-4 软件的可维护与复用设计原则 7-5 面向对象的设计与分析 章节练习 8-1 内部类与包装器 8-2 对象包装器 8-3 装箱和拆箱 8-4 练习题 9-1 常用类介绍 9-2 StringBuffer和String Builder类 9-3 Rintime类的使用 9-4 日期类简介 9-5 java程序国际化的实现 9-6 Random类和Math类 9-7 枚举 9-8 练习题 10-1 java异常处理 10-2 认识异常 10-3 使用try和catch捕获异常 10-4 使用throw和throws引发异常 10-5 finally关键字 10-6 getMessage和printStackTrace方法 10-7 异常分类 10-8 自定义异常类 10-9 练习题 11-1 Java集合框架和泛型机制 11-2 Collection接口 11-3 Set接口实现类 11-4 List接口实现类 11-5 Map接口 11-6 Collections类 11-7 泛型概述 11-8 练习题 12-1 多线程 12-2 线程的生命周期 12-3 线程的调度和优先级 12-4 线程的同步 12-5 集合类的同步问题 12-6 用Timer类调度任务 12-7 练习题 13-1 Java IO 13-2 Java IO原理 13-3 流类的结构 13-4 文件流 13-5 缓冲流 13-6 转换流 13-7 数据流 13-8 打印流 13-9 对象流 13-10 随机存取文件流 13-11 zip文件流 13-12 练习题 14-1 图形用户界面设计 14-2 事件处理机制 14-3 AWT常用组件 14-4 swing简介 14-5 可视化开发swing组件 14-6 声音的播放和处理 14-7 2D图形的绘制 14-8 练习题 15-1 反射 15-2 使用Java反射机制 15-3 反射与动态代理 15-4 练习题 16-1 Java标注 16-2 JDK内置的基本标注类型 16-3 自定义标注类型 16-4 对标注进行标注 16-5 利用反射获取标注信息 16-6 练习题 17-1 顶目实战1-单机版五子棋游戏 17-2 总体设计 17-3 代码实现 17-4 程序的运行与发布 17-5 手动生成可执行JAR文件 17-6 练习题 18-1 Java数据库编程 18-2 JDBC类和接口 18-3 JDBC操作SQL 18-4 JDBC基本示例 18-5 JDBC应用示例 18-6 练习题 19-1 。。。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值