ROADS

题目:

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash.

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.

输入:

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.
The second line contains the integer N, 2 <= N <= 100, the total number of cities.

The third line contains the integer R, 1 <= R <= 10000, the total number of roads.

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :

  • S is the source city, 1 <= S <= N
  • D is the destination city, 1 <= D <= N
  • L is the road length, 1 <= L <= 100
  • T is the toll (expressed in the number of coins), 0 <= T <=100


Notice that different roads may have the same source and destination cities.

输出:

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.
If such path does not exist, only number -1 should be written to the output.

样例输入:

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

样例输出:

11

这题的意思就是从一个城市到另一个城市在有限的费用下走的最短路程是多少。

是个最短路的题目,但是我觉得用邻接表+dfs理解起来更容易一些。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
int cnt=0;
const int maxn=1e4+5;
const int INF=0x7fffffff;
int head[maxn];
int vis[maxn];
int k,n,r,minn;
struct node
{
    int u,v,w,l;
    int next;
}Node[maxn];
void add(int u,int v,int w,int l)
{
    Node[cnt].u=u;
    Node[cnt].v=v;
    Node[cnt].w=w;
    Node[cnt].l=l;
    Node[cnt].next=head[u];
    head[u]=cnt++;
}
void dfs(int a,int b,int c)//a代表当前城市,b代表已经走过的路程,c代表目前还有多少费用
{
    if(a==n)//如果到达n城市,再比较路程,要最小的路程
    {
        if(b<=minn)
            minn=b;
        return ;
    }
    for(int i=head[a];i!=-1;i=Node[i].next)
    {
        //如果当前城市连着的下一个城市没有被标记
         //并且已经走过的路程加上要走的这一段比当前的minn还小
        //并且费用还要够走完这段路的话,就继续搜索
        if(!vis[Node[i].v]&&b+Node[i].w<minn&&c-Node[i].l>=0)
        {
            vis[Node[i].v]=1;
            dfs(Node[i].v,b+Node[i].w,c-Node[i].l);
            vis[Node[i].v]=0;
        }
    }
}
int main()
{
    scanf("%d%d%d",&k,&n,&r);
    minn=INF;
    memset(head,-1,sizeof(head));
    memset(vis,0,sizeof(vis));
    for(int i=0;i<r;i++)
    {
        int u,v,w,l;
        scanf("%d%d%d%d",&u,&v,&w,&l);
        add(u,v,w,l);
    }
    vis[1]=1;
    dfs(1,0,k);
    if(minn==INF)
        printf("-1\n");
    else
        printf("%d\n",minn);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值