Cleaning Shifts (贪心)

Cleaning Shifts

 

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input
* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
Output
* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.
Sample Input
3 10
1 7
3 6
6 10
Sample Output
2
Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

OUTPUT DETAILS: 

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

题意:每个牛都有开始工作的时间区间,问完成所有的工作,至少需要几头牛,如果完不成,则输出-1.此题与今年暑假不ac相似,但是本题使用的是前排序,而且,此题中有个陷阱,如1号牛完成了1-7,2号牛从8或者8之前开始工作即可,即:若1--7  ,8--10这样的情况不会输出-1

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 50005
using namespace std;

struct note
{
	int l,r;
}a[maxn];
bool cmp(note a,note b){
	if(a.l==b.l)
		return a.r<b.r;
	return a.l<b.l;
}
int main()
{
	int n,T;
    scanf("%d%d",&n,&T);
    for (int i=1;i<=n;++i)
        scanf("%d%d",&a[i].l,&a[i].r);
    sort(a,a+n,cmp);
    a[n+1].l=1000009;
   // for (int i=1;i<=n;++i) printf("%d %d\n",a[i].l,a[i].r);
    int t=0,temp=0,ans=0;
    int flag=0;
    for (int i=1;i<=n;++i){
        if (a[i].l<=t+1){
            if (temp<a[i].r){
            	temp=a[i].r;
				flag=1;
            }
            if (a[i+1].l>t+1&&flag){
                t=temp;
				++ans;
				flag=0;
            }
        }
    }
    if (t<T) printf("-1\n");
	else printf("%d\n",ans);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值