A Knight's Journey (dfs)

B - A Knight's Journey

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey  around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
 

题意:判断一个骑士能否走遍整个地图,如果可以按字典序输出,如果不可以输出impossible。

思路:因为要按字典序输出,所以我们只用从A1开始搜索就可以了,因为如果A1时发现有格子到不了,那么如果从其他地方开始搜索,也一定会有格子搜索不到的,反之,如果从某个格子开始搜索,能走遍所有格子,那么也一定能到A1,因此,我们只需要从A1开始搜素就可以了,代码就不注释了,还是比较容易懂的。

AC代码:

import java.util.Arrays;
import java.util.*;

public class Main 	{
	static int n,m,step,flag;
	static int [][]vis = new int[100][100];
	static int [][]path = new int[100][100];
	static int [][]d = {{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
	public static void main(String[] args){
		Scanner cin = new Scanner(System.in);
		int T = cin.nextInt();
		int t = T;
		while(T--!=0){
			n = cin.nextInt();
			m = cin.nextInt();
			for(int i=0;i<=n;++i){
				for(int j=0;j<=m;++j){
					vis[i][j] = 0;
				}
			}
			flag=0;
			vis[1][1] = 1;
			dfs(1,1,1);
			System.out.println("Scenario #"+(t-T)+":");
			if(flag==1){
				for(int i=1;i<=n*m;++i){
					char c=(char)(path[i][1]+64);
					System.out.print(c);
					System.out.print(path[i][0]);
				}
				System.out.println();
			}
			else
				System.out.println("impossible");
			if(T!=0)
				System.out.println();
		}
	}
	static void dfs(int x,int y,int step){
		path[step][0] = x;
		path[step][1] = y;
		if(step == n*m){
			flag = 1;
			return ;
		}
		for(int i=0;i<8;++i){
			int nx = x+d[i][0];
			int ny = y+d[i][1];
			if(judge(nx,ny)){	
				vis[nx][ny] = 1;
				dfs(nx,ny,step+1);
				vis[nx][ny] = 0;
			}
		}
	}
	static  Boolean judge(int x,int y){
		if(x<1||x>n||y<1||y>m)	return false;
		if(vis[x][y] == 1)		return false;
		if(flag == 1)			return false;
		return true;
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值