Period POJ - 1961 (KMP扩展—next数组应用)

                                               Period  POJ - 1961 

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题意:已知长度为n的字符串,让求i位置之前的字符串是由多少个相同的字符串拼接而成的,例如aabaabaabaab第2个位置之前为aa,是由两个a拼接而成,第6个位置之前是aabaab是由两个相同的aab组成。输出i以及相同的字串数

思路:同poj2406,next数组的扩展应用

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<utility>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<stack>
#define maxn1 1000005
#define maxn2 10005
#define INF 0x3f3f3f3f
#define LL long long
#define ULL unsigned long long
#define E 1e-8
#define mod 1000000007
#define P pair<int,int>
using namespace std;
 
int n;
char str[1000001];
int nexts[1000001];
void GetNexts(){
    int j=0,k=-1;
    nexts[0]=-1;
    while(j<n){
        if(k==-1||str[j]==str[k]){
            j++;
            k++;
            nexts[j]=k;
        }
        else k=nexts[k];
    }
}
int main(){
    int T = 0;
    while(scanf("%d",&n)!=EOF&&n){
        scanf("%s",str);
        GetNexts();
        printf("Test case #%d\n",++T);
        for(int i=1;i<=n;++i){
            int len = i-nexts[i];
            if(nexts[i]>0&&i%len==0)
                printf("%d %d\n",i,i/len);
        }
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值