hdoj1002A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 266282    Accepted Submission(s): 51573


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
    一看就是大数!!
  代码:
 
#include<stdio.h>
#include<string.h>
char  al[1010],bl[1010];
int a[1010],b[1010];
int main()
{
    int i,j,n;
    scanf("%d",&n);
    getchar();
    int k=1;
     while(n--)
    {
        scanf("%s",al);//存为字符串 
        scanf("%s",bl);
        int l1=strlen(al);
        int l2=strlen(bl);
        memset(a,0,sizeof(a));//初始化 
        memset(b,0,sizeof(b));
        printf("Case %d:\n",k++);
        for(j=0,i=l1-1;i>=0;i--)//转化为数字 
          {
              a[j]=al[i]-'0';
              j++;
          }
          for(j=0,i=l2-1;i>=0;i--)
           {
               b[j]=bl[i]-'0';
               j++;
           }
           for(i=0;i<1009;i++)//位位相加 
              {
                  a[i]=a[i]+b[i];
                  if(a[i]>=10)
                  {
                      a[i]-=10;
                     a[i+1]++;//如果大于十下一位加一 
                }
              }
              printf("%s + %s = ",al,bl);
              for(i=1009;i>=0;i--)
              {
                  if(a[i]!=0)//去掉前导零 
                    break;
              }
              if(i>=0)
               for(;i>=0;i--)
                 {
                     printf("%d",a[i]);
                 }
                 printf("\n"); 
                 if(n!=0)
                 printf("\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值