hdoj 5532 Almost Sorted Array

Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1716    Accepted Submission(s): 455


Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array  a1,a2,,an , is it almost sorted?
 

Input
The first line contains an integer  T  indicating the total number of test cases. Each test case starts with an integer  n  in one line, then one line with  n  integers  a1,a2,,an .

1T2000
2n105
1ai105
There are at most 20 test cases with  n>1000 .
 

Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
  
  
3 3 2 1 7 3 3 2 1 5 3 1 4 1 5
 

Sample Output
  
  
YES YES NO
这个需要二分求解,不然超时!
AC代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define  N 100100
int  a[N],b[N],t[N];
int  Find(int left,int right,int val)//二分查找 适合位置 
{
	int  mid;
	while(right>=left)
	{
	mid=(left+right)/2;
	if(t[mid]>val)
	right=mid-1;
	else
	left=mid+1;
    }
    return left;
}
int main()
{
	int  T;
	scanf("%d",&T);
	while(T--)
	{
		int  n,m,j,i; 
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			b[n+1-i]=a[i];
		}
		t[1]=a[1];
		int  top=1;
		for(i=2;i<=n;i++)
		{
			if(a[i]>=t[top])//从小到大 ,,正向 
			t[++top]=a[i];
			else
			{
				int  temp=Find(1,top+1,a[i]);
				t[temp]=a[i];
			}
		}
		if(n-top<=1)
		{
			printf("YES\n");
			continue;
		}
		top=1;
		t[1]=b[1];
		for(i=2;i<=n;i++)//从大到小 
		{
			if(b[i]>=t[top])
			t[++top]=b[i];
			else
			{
				int temp=Find(1,top+1,b[i]);
				t[temp]=b[i];
			}
		}
		if(n-top<=1)
	    printf("YES\n");
	    else
	    printf("NO\n");
	}
	return 0;
} 


超时代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define N  100100
#define  INF 0x3f3f3f
int main()
{
    int  T,n,m;
    scanf("%d",&T);
    while(T--)
    {
        int  i,j;
        int a[N];
        scanf("%d",&n);
        for(i=1;i<=n;i++)
        scanf("%d",&a[i]);
        int  dp1[N],dp2[N];
        memset(dp1,0,sizeof(dp1)); 
        memset(dp2,0,sizeof(dp2));
        for(i=n-1;i>0;i--) 
         for(j=i+1;j<=n;j++)
         {
             if(a[j]<=a[i]&&dp1[i]<=dp1[j])//从小到大
             dp1[i]=dp1[j]+1;
            if(a[j]>=a[i]&&dp2[i]<=dp2[j])//从大到小 
            dp2[i]=dp2[j]+1;
         }
         int  max1=0,max2=0;
         for(i=1;i<=n;i++)
         {
             if(max1<dp1[i])
             {    
             max1=dp1[i];
//              count1++;
            }
             if(max2<dp2[i])
             {    
              max2=dp2[i];
//              count2++;
            }
         }
        if(max1<=1||max2<=1)
         printf("YES\n");
         else
         printf("NO\n");
    }
    return  0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值